aboutsummaryrefslogtreecommitdiff
path: root/ftp/kbear
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2004-06-06 01:27:57 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2004-06-06 01:27:57 +0000
commit1812ad0a8e8a3c77a8ed76d7b7c8c7bb9d96044c (patch)
treecfe28ae7d005c9aca020dad8667daacac8f8142e /ftp/kbear
parent998504ed5d6fe71718213ff3e9bd590329805fa4 (diff)
downloadports-1812ad0a8e8a3c77a8ed76d7b7c8c7bb9d96044c.tar.gz
ports-1812ad0a8e8a3c77a8ed76d7b7c8c7bb9d96044c.zip
Notes
Diffstat (limited to 'ftp/kbear')
-rw-r--r--ftp/kbear/Makefile9
-rw-r--r--ftp/kbear/files/patch-transferqueueconfigwidget.cpp11
2 files changed, 15 insertions, 5 deletions
diff --git a/ftp/kbear/Makefile b/ftp/kbear/Makefile
index 43017fba22ea..8e806b44f4b9 100644
--- a/ftp/kbear/Makefile
+++ b/ftp/kbear/Makefile
@@ -22,11 +22,10 @@ USE_REINPLACE= yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= XML2POT=${TRUE} PO2XML=${TRUE}
+CONFIGURE_ENV= XML2POT=${TRUE} PO2XML=${TRUE} LDFLAGS="${PTHREAD_LIBS}"
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ftp/kbear/files/patch-transferqueueconfigwidget.cpp b/ftp/kbear/files/patch-transferqueueconfigwidget.cpp
new file mode 100644
index 000000000000..93716ce26046
--- /dev/null
+++ b/ftp/kbear/files/patch-transferqueueconfigwidget.cpp
@@ -0,0 +1,11 @@
+--- kbear/plugins/transferqueue/transferqueueconfigwidget.cpp.orig Sun Jun 6 03:12:32 2004
++++ kbear/plugins/transferqueue/transferqueueconfigwidget.cpp Sun Jun 6 03:13:35 2004
+@@ -110,7 +110,7 @@
+ m_config->sync();
+ }
+ m_sysShutdownCheckBox->setChecked( m_config->readBoolEntry( QString::fromLatin1("SysShutdownWhenDone"), false ) );
+- m_queueCheckBox->setChecked( m_config->readBoolEntry( QString::fromLatin1("QueueTransfers"), false ) );
++ m_queueCheckBox->setChecked( m_config->readBoolEntry( QString::fromLatin1("QueueTransfers"), true ) );
+ m_countSpinBox->setValue( m_config->readUnsignedNumEntry( QString::fromLatin1("NumberOfTransfers"), 1 ) );
+ m_disconnectCommandLineEdit->setText( m_config->readEntry( QString::fromLatin1("DisconnectCommand"), QString::fromLatin1("kppp -k") ) );
+