aboutsummaryrefslogtreecommitdiff
path: root/ftp/lftp/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-19 12:50:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-19 12:50:42 +0000
commit511ea3352d9b6d6efd9967c6ebbef480d298352a (patch)
tree0098a4b50efa7b68f3bfd0295638fb1cd0346048 /ftp/lftp/Makefile
parenteb5deb022870156cfb0e21d2b23364445e8aea3e (diff)
downloadports-511ea3352d9b6d6efd9967c6ebbef480d298352a.tar.gz
ports-511ea3352d9b6d6efd9967c6ebbef480d298352a.zip
Notes
Diffstat (limited to 'ftp/lftp/Makefile')
-rw-r--r--ftp/lftp/Makefile28
1 files changed, 17 insertions, 11 deletions
diff --git a/ftp/lftp/Makefile b/ftp/lftp/Makefile
index 6f5791e4d8fb..56dafafbc452 100644
--- a/ftp/lftp/Makefile
+++ b/ftp/lftp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lftp
-PORTVERSION= 3.7.15
-PORTREVISION= 1
+PORTVERSION= 4.0.0
CATEGORIES= ftp ipv6
MASTER_SITES= ftp://ftp.st.ryukoku.ac.jp/pub/network/ftp/lftp/ \
ftp://ftp.st.ryukoku.ac.jp/pub/network/ftp/lftp/old/ \
@@ -36,8 +35,8 @@ PORTDOCS= AUTHORS BUGS ChangeLog FAQ FEATURES INSTALL \
MIRRORS NEWS README README.debug-levels README.modules \
THANKS TODO
-OPTIONS= GNUTLS "With GnutTLS support" off \
- OPENSSL "With OpenSSL support" on \
+OPTIONS= OPENSSL "With OpenSSL support" on \
+ GNUTLS "With GnutTLS support" off \
NLS "With i18n support" on
.include <bsd.port.pre.mk>
@@ -47,13 +46,6 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libreadline.so.6:${PORTSDIR}/devel/readline
RUN_DEPENDS+= ${LOCALBASE}/lib/libreadline.so.6:${PORTSDIR}/devel/readline
.endif
-.if defined(WITH_GNUTLS)
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
-CONFIGURE_ARGS+= --with-gnutls
-.else
-CONFIGURE_ARGS+= --without-gnutls
-.endif
-
.if !defined(WITHOUT_OPENSSL)
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS+= --with-openssl
@@ -61,6 +53,13 @@ CONFIGURE_ARGS+= --with-openssl
CONFIGURE_ARGS+= --without-openssl
.endif
+.if defined(WITH_GNUTLS)
+LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+CONFIGURE_ARGS+= --with-gnutls
+.else
+CONFIGURE_ARGS+= --without-gnutls
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
CONFIGURE_ARGS+= --enable-nls
@@ -72,6 +71,13 @@ PLIST_SUB+= NLS="@comment "
MAN1= lftp.1 lftpget.1
+pre-configure:
+.if !defined(WITHOUT_OPENSSL) && defined(WITH_GNUTLS)
+ @${ECHO_MSG} "========"
+ @${ECHO_MSG} "WARNING: both OPENSSL and GNUTLS have been selected, OPENSSL will be used"
+ @${ECHO_MSG} "========"
+.endif
+
post-install:
@${INSTALL_DATA} ${WRKSRC}/lftp.conf ${PREFIX}/etc/lftp.conf.sample
@if [ ! -f ${PREFIX}/etc/lftp.conf ]; then \