aboutsummaryrefslogtreecommitdiff
path: root/ftp/lftp
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-27 21:40:13 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-27 21:40:13 +0000
commit183f7b55c0200e876dabbb06b6bf6d726bbe360e (patch)
tree7a63ff1d1c887d16e8faaf4e033f6a3335910dae /ftp/lftp
parentb030b015dedf5180ca77147e15a1ac327fc72078 (diff)
downloadports-183f7b55c0200e876dabbb06b6bf6d726bbe360e.tar.gz
ports-183f7b55c0200e876dabbb06b6bf6d726bbe360e.zip
Notes
Diffstat (limited to 'ftp/lftp')
-rw-r--r--ftp/lftp/Makefile27
-rw-r--r--ftp/lftp/distinfo8
-rw-r--r--ftp/lftp/files/patch-src-lftp_rl.c13
3 files changed, 25 insertions, 23 deletions
diff --git a/ftp/lftp/Makefile b/ftp/lftp/Makefile
index 2b525a44bdd5..2252c4df0240 100644
--- a/ftp/lftp/Makefile
+++ b/ftp/lftp/Makefile
@@ -6,30 +6,19 @@
#
PORTNAME= lftp
-PORTVERSION= 3.3.0
+PORTVERSION= 3.3.3
CATEGORIES= ftp ipv6
-MASTER_SITES= ftp://ftp.cs.tu-berlin.de/pub/net/ftp/lftp/ \
- ftp://ftp.phear.org/pub/linux/networking/ftp/client/lftp/ \
- ftp://ftp.phear.org/pub/linux/networking/ftp/client/lftp/old/ \
- http://the.wiretapped.net/mirrors/lftp/ \
- http://the.wiretapped.net/mirrors/lftp/old/ \
- ftp://ftp.ayamura.org/pub/lftp/ \
- ftp://ftp.ayamura.org/pub/lftp/old/ \
- ftp://ftp.st.ryukoku.ac.jp/pub/network/ftp/lftp/ \
- ftp://ftp.st.ryukoku.ac.jp/pub/network/ftp/lftp/old/ \
- ftp://the.ausmac.net/pub/mirrors/lftp/ \
- ftp://the.ausmac.net/pub/mirrors/lftp/old/ \
- ftp://ftp.bme.hu/packages/lftp/ \
- ftp://ftp.bme.hu/packages/lftp/old/ \
- ftp://ftp.tuwien.ac.at/infosys/browsers/ftp/lftp/ \
- ftp://ftp.tuwien.ac.at/infosys/browsers/ftp/lftp/old/ \
- ftp://ftp.cs.tu-berlin.de/pub/net/ftp/lftp/old/ \
+MASTER_SITES= \
ftp://mirror.widexs.nl/pub/lftp/ \
ftp://mirror.widexs.nl/pub/lftp/old/ \
ftp://ftp.130th.net/pub/mirror/lftp/ \
ftp://ftp.130th.net/pub/mirror/lftp/old/ \
- ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/ \
- ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/old/
+ ftp://ftp.iasi.roedu.net/pub/os/Linux/network/ftp/lftp/ \
+ ftp://ftp.iasi.roedu.net/pub/os/Linux/network/ftp/lftp/old/ \
+ ftp://ftp.yars.free.net/pub/source/lftp/ \
+ ftp://ftp.yars.free.net/pub/source/lftp/old/ \
+ ftp://lftp.yar.ru/lftp/ \
+ ftp://lftp.yar.ru/lftp/old/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/ftp/lftp/distinfo b/ftp/lftp/distinfo
index 6e5115502eb0..d53cc3e076a2 100644
--- a/ftp/lftp/distinfo
+++ b/ftp/lftp/distinfo
@@ -1,4 +1,4 @@
-MD5 (lftp-3.3.0.tar.bz2) = 5f06462c88618ecd61db8e46ef494bc3
-SIZE (lftp-3.3.0.tar.bz2) = 1262865
-MD5 (lftp-3.3.0.tar.bz2.asc) = 3ac945ba9b5ae8b819ddd5e3813216ec
-SIZE (lftp-3.3.0.tar.bz2.asc) = 185
+MD5 (lftp-3.3.3.tar.bz2) = 92f2c10ee4460a9e4654615db0f3f8ab
+SIZE (lftp-3.3.3.tar.bz2) = 1265962
+MD5 (lftp-3.3.3.tar.bz2.asc) = 7c2d890ee672bb8b6f145ee14f5eb14c
+SIZE (lftp-3.3.3.tar.bz2.asc) = 185
diff --git a/ftp/lftp/files/patch-src-lftp_rl.c b/ftp/lftp/files/patch-src-lftp_rl.c
new file mode 100644
index 000000000000..4d2fd23d534d
--- /dev/null
+++ b/ftp/lftp/files/patch-src-lftp_rl.c
@@ -0,0 +1,13 @@
+--- src/lftp_rl.c.orig Tue Oct 18 11:21:22 2005
++++ src/lftp_rl.c Fri Oct 21 21:55:00 2005
+@@ -191,9 +191,9 @@
+ if(!lftp_history_file)
+ {
+ const char *home=get_lftp_home();
++ const char *add="/rl_history";
+ if(!home)
+ return;
+- const char *add="/rl_history";
+ lftp_history_file=(char*)malloc(strlen(home)+strlen(add)+1);
+ strcat(strcpy(lftp_history_file,home),add);
+ }