aboutsummaryrefslogtreecommitdiff
path: root/ftp/libfilezilla/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2016-02-05 17:37:29 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2016-02-05 17:37:29 +0000
commitc05148a4ebc9c3581261e33e8ab30bb3a57e5272 (patch)
treeb7d3fe60227f53a24aee5f4d5bb6d60a1ff2a340 /ftp/libfilezilla/Makefile
parent5f510cdf8c39f8e8a3045978ab712f56543cba89 (diff)
Notes
Diffstat (limited to 'ftp/libfilezilla/Makefile')
-rw-r--r--ftp/libfilezilla/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/ftp/libfilezilla/Makefile b/ftp/libfilezilla/Makefile
new file mode 100644
index 000000000000..eedab16d1580
--- /dev/null
+++ b/ftp/libfilezilla/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= libfilezilla
+PORTVERSION= 0.3.1
+CATEGORIES= ftp
+MASTER_SITES= SF/filezilla/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= matthew@reztek.cz
+COMMENT= C++ library for building platform-independent programs
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BROKEN_FreeBSD_9= requires C++14 complier, 9.x lacks C++11 standard library
+
+USES= compiler:c++14-lang gmake libtool localbase pathfix pkgconfig tar:bzip2
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>