aboutsummaryrefslogtreecommitdiff
path: root/ftp/libfxp/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-02-05 11:32:33 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-02-05 11:32:33 +0000
commitfcac30e7e57e4a564337599577ae8db184a0c20a (patch)
treedd8f093608512a759ecb21b99de37b624f862a6b /ftp/libfxp/Makefile
parent3485e83f138b5bf4d896d7a4ab6b35bd8ee53a20 (diff)
downloadports-fcac30e7e57e4a564337599577ae8db184a0c20a.tar.gz
ports-fcac30e7e57e4a564337599577ae8db184a0c20a.zip
Notes
Diffstat (limited to 'ftp/libfxp/Makefile')
-rw-r--r--ftp/libfxp/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/ftp/libfxp/Makefile b/ftp/libfxp/Makefile
new file mode 100644
index 000000000000..6fa900a58867
--- /dev/null
+++ b/ftp/libfxp/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# New ports collection makefile for: libfxp
+# Date created: Feb 5, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libfxp
+PORTVERSION= 0.1.4
+CATEGORIES= ftp
+MASTER_SITES= http://millweed.com/projects/libfxp/
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_GMAKE= yes
+CFLAGS+= -I. -Ilibmillweed
+
+post-patch:
+.for file in Makefile libmillweed/Makefile
+ @${PERL} -pi -e "s,^CC,#CC,g ; \
+ s,^CFLAGS,#CFLAGS,g ; \
+ s,^PREFIX,#PREFIX,g" ${WRKSRC}/${file}
+.endfor
+ @(cd ${WRKSRC} ; \
+ ${GREP} -l -R malloc.h * | xargs \
+ ${PERL} -pi -e "s|malloc.h|stdlib.h|g")
+
+.include <bsd.port.mk>