aboutsummaryrefslogtreecommitdiff
path: root/ftp/libfxp
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-02-05 11:32:33 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-02-05 11:32:33 +0000
commitfcac30e7e57e4a564337599577ae8db184a0c20a (patch)
treedd8f093608512a759ecb21b99de37b624f862a6b /ftp/libfxp
parent3485e83f138b5bf4d896d7a4ab6b35bd8ee53a20 (diff)
downloadports-fcac30e7e57e4a564337599577ae8db184a0c20a.tar.gz
ports-fcac30e7e57e4a564337599577ae8db184a0c20a.zip
Notes
Diffstat (limited to 'ftp/libfxp')
-rw-r--r--ftp/libfxp/Makefile29
-rw-r--r--ftp/libfxp/distinfo1
-rw-r--r--ftp/libfxp/pkg-comment1
-rw-r--r--ftp/libfxp/pkg-descr3
-rw-r--r--ftp/libfxp/pkg-plist7
5 files changed, 41 insertions, 0 deletions
diff --git a/ftp/libfxp/Makefile b/ftp/libfxp/Makefile
new file mode 100644
index 000000000000..6fa900a58867
--- /dev/null
+++ b/ftp/libfxp/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# New ports collection makefile for: libfxp
+# Date created: Feb 5, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libfxp
+PORTVERSION= 0.1.4
+CATEGORIES= ftp
+MASTER_SITES= http://millweed.com/projects/libfxp/
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_GMAKE= yes
+CFLAGS+= -I. -Ilibmillweed
+
+post-patch:
+.for file in Makefile libmillweed/Makefile
+ @${PERL} -pi -e "s,^CC,#CC,g ; \
+ s,^CFLAGS,#CFLAGS,g ; \
+ s,^PREFIX,#PREFIX,g" ${WRKSRC}/${file}
+.endfor
+ @(cd ${WRKSRC} ; \
+ ${GREP} -l -R malloc.h * | xargs \
+ ${PERL} -pi -e "s|malloc.h|stdlib.h|g")
+
+.include <bsd.port.mk>
diff --git a/ftp/libfxp/distinfo b/ftp/libfxp/distinfo
new file mode 100644
index 000000000000..a416ae7bcc11
--- /dev/null
+++ b/ftp/libfxp/distinfo
@@ -0,0 +1 @@
+MD5 (libfxp-0.1.4.tar.gz) = 8dde4bf6826ca9a5cd4ba71f00284d56
diff --git a/ftp/libfxp/pkg-comment b/ftp/libfxp/pkg-comment
new file mode 100644
index 000000000000..5414b386c443
--- /dev/null
+++ b/ftp/libfxp/pkg-comment
@@ -0,0 +1 @@
+An ftp client library
diff --git a/ftp/libfxp/pkg-descr b/ftp/libfxp/pkg-descr
new file mode 100644
index 000000000000..e05fa458f455
--- /dev/null
+++ b/ftp/libfxp/pkg-descr
@@ -0,0 +1,3 @@
+An ftp client library
+
+WWW: http://millweed.com/projects/libfxp/
diff --git a/ftp/libfxp/pkg-plist b/ftp/libfxp/pkg-plist
new file mode 100644
index 000000000000..dca0295a4217
--- /dev/null
+++ b/ftp/libfxp/pkg-plist
@@ -0,0 +1,7 @@
+include/fxp.h
+include/millweed/list.h
+include/millweed/misc.h
+include/millweed/net.h
+include/millweed/parse.h
+lib/libfxp.a
+@dirrm include/millweed