aboutsummaryrefslogtreecommitdiff
path: root/ftp/lukemftpd/Makefile
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2001-04-13 09:08:12 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2001-04-13 09:08:12 +0000
commitaff4d9e5b10be78d8258db45533e2ba247d0c00f (patch)
tree1342dc0755e0799da4441c869b205cd3fb861e31 /ftp/lukemftpd/Makefile
parent7645c60ab39c27c86eb6f301a2b509d85c74303e (diff)
downloadports-aff4d9e5b10be78d8258db45533e2ba247d0c00f.tar.gz
ports-aff4d9e5b10be78d8258db45533e2ba247d0c00f.zip
Notes
Diffstat (limited to 'ftp/lukemftpd/Makefile')
-rw-r--r--ftp/lukemftpd/Makefile64
1 files changed, 64 insertions, 0 deletions
diff --git a/ftp/lukemftpd/Makefile b/ftp/lukemftpd/Makefile
new file mode 100644
index 000000000000..0b5423eb4aed
--- /dev/null
+++ b/ftp/lukemftpd/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: lukemftpd
+# Date created: 12 April 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lukemftpd
+PORTVERSION= 1.0
+CATEGORIES= ftp ipv6
+MASTER_SITES= ftp://ftp.netbsd.org/pub/NetBSD/misc/lukemftp/ \
+ ftp://ftp.nuug.no/pub/anders/distfiles/
+
+MAINTAINER= anders@fix.no
+
+GNU_CONFIGURE= yes
+
+DOCS= ChangeLog README THANKS
+
+MAN5= ftpd.conf.5 ftpusers.5
+MAN8= ftpd.8
+
+FIXPREFIX= ftpd.8 ftpd.conf.5 ftpusers.5
+
+pre-patch:
+.for f in ${FIXPREFIX}
+ ${PERL} -pi -e "s@^\.Dq Pa /etc@.Dq Pa ${PREFIX}/etc@g; \
+ s@^\.Pa /etc@.Pa ${PREFIX}/etc@g; \
+ s@^\.It Pa /etc/@.It Pa ${PREFIX}/etc/@g; \
+ s@^\.Ss /etc/@.Ss ${PREFIX}/etc/@g; \
+ s@^\.Sx /etc/@.Sx ${PREFIX}/etc/@g; \
+ s@^\.Bl -tag -width /etc/@.Bl -tag -width ${PREFIX}/etc/@g; \
+ s@${PREFIX}/etc/shells@/etc/shells@g; \
+ s@${PREFIX}/etc/pwd.db@/etc/pwd.db@g" \
+ ${WRKSRC}/src/${f}
+.endfor
+ ${PERL} -pi -e \
+ "s@^#define\t_DEFAULT_CONFDIR\t\"/etc\"@#define\t_DEFAULT_CONFDIR\t\"${PREFIX}/etc\"@" \
+ ${WRKSRC}/src/pathnames.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/ftpd ${PREFIX}/libexec/ftpd
+ ${INSTALL_MAN} ${WRKSRC}/src/ftpd.8 ${PREFIX}/man/man8
+ ${INSTALL_MAN} ${WRKSRC}/src/ftpd.conf.5 ${PREFIX}/man/man5
+ ${INSTALL_MAN} ${WRKSRC}/src/ftpusers.5 ${PREFIX}/man/man5
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/lukemftpd
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/lukemftpd/
+.endfor
+.endif
+
+post-install:
+ @${ECHO} "================================================================================"
+ @${ECHO} "This port relies on a number of configuration files in ${PREFIX}/etc."
+ @${ECHO} "At the very least, create a ftpusers file with the usernams of users you don't"
+ @${ECHO} "want to connect (root, toor, etc.). This will allow non-listed users to log in."
+ @${ECHO} "Copying /etc/ftpusers to ${PREFIX}/etc/ftpusers should be sufficient."
+ @${ECHO}
+ @${ECHO} "See the man files for more information. The man- and configuration files for"
+ @${ECHO} "FreeBSD's built-in ftpd can also be of use as examples/additional info."
+ @${ECHO} "================================================================================"
+
+.include <bsd.port.mk>