aboutsummaryrefslogtreecommitdiff
path: root/ftp/ncftp3
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2001-05-12 02:13:40 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2001-05-12 02:13:40 +0000
commit5414730c2a7f75f41bfad7de67b808542a56de88 (patch)
tree83c2d4d555487476af30a9b5c335b338aa961da3 /ftp/ncftp3
parentf192ad9ee694f4fb8c90dff091d7799517785be2 (diff)
downloadports-5414730c2a7f75f41bfad7de67b808542a56de88.tar.gz
ports-5414730c2a7f75f41bfad7de67b808542a56de88.zip
- replace post-patch munging with proper SYSCONFDIR handling (also
submitted to Mike Gleason) - improve DESCR and add home page Submitted by: Christian Weisgerber <naddy@mips.inka.de>
Notes
Notes: svn path=/head/; revision=42546
Diffstat (limited to 'ftp/ncftp3')
-rw-r--r--ftp/ncftp3/Makefile5
-rw-r--r--ftp/ncftp3/files/patch-ncftp-Makefile.in19
-rw-r--r--ftp/ncftp3/files/patch-pref.h17
-rw-r--r--ftp/ncftp3/files/patch-sh_util-Makefile.in18
-rw-r--r--ftp/ncftp3/files/patch-vis-Makefile.in19
-rw-r--r--ftp/ncftp3/pkg-comment2
-rw-r--r--ftp/ncftp3/pkg-descr16
7 files changed, 85 insertions, 11 deletions
diff --git a/ftp/ncftp3/Makefile b/ftp/ncftp3/Makefile
index c4aa4eca0111..8d10fc691455 100644
--- a/ftp/ncftp3/Makefile
+++ b/ftp/ncftp3/Makefile
@@ -29,11 +29,6 @@ MAN3= Strn.3
LIBNCFTP= libncftp.so.2
LIBSTRN= libStrn.so.1
-post-patch:
- @${MV} ${WRKSRC}/ncftp/pref.h ${WRKSRC}/ncftp/pref.h.in
- @${SED} -e 's:/etc/ncftp.firewall:${PREFIX}/etc/ncftp.firewall:' \
- ${WRKSRC}/ncftp/pref.h.in > ${WRKSRC}/ncftp/pref.h
-
pre-build:
cd ${WRKSRC}/Strn ; make so
cd ${WRKSRC}/libncftp ; make so
diff --git a/ftp/ncftp3/files/patch-ncftp-Makefile.in b/ftp/ncftp3/files/patch-ncftp-Makefile.in
new file mode 100644
index 000000000000..275153033470
--- /dev/null
+++ b/ftp/ncftp3/files/patch-ncftp-Makefile.in
@@ -0,0 +1,19 @@
+--- ncftp/Makefile.in.orig Fri Dec 8 23:11:08 2000
++++ ncftp/Makefile.in Tue May 8 13:42:15 2001
+@@ -13,6 +13,7 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ BINDIR=@bindir@
++SYSCONFDIR=@sysconfdir@
+
+ LIBS=@LIBS@
+ STRIP=strip
+@@ -20,7 +21,7 @@
+
+ # Any -D definitions:
+ BETA=# -DBETA=20
+-DEFS=-Dncftp $(BETA) -DBINDIR=\"$(BINDIR)\" @DEFS@
++DEFS=-Dncftp $(BETA) -DBINDIR=\"$(BINDIR)\" -DSYSCONFDIR=\"$(SYSCONFDIR)\" @DEFS@
+
+ OBJS=cmds.@OBJEXT@ cmdlist.@OBJEXT@ getopt.@OBJEXT@ ls.@OBJEXT@ main.@OBJEXT@ version.@OBJEXT@ shell.@OBJEXT@ util.@OBJEXT@ readln.@OBJEXT@ progress.@OBJEXT@ bookmark.@OBJEXT@ pref.@OBJEXT@ preffw.@OBJEXT@ trace.@OBJEXT@ spool.@OBJEXT@ log.@OBJEXT@ getline.@OBJEXT@
+
diff --git a/ftp/ncftp3/files/patch-pref.h b/ftp/ncftp3/files/patch-pref.h
new file mode 100644
index 000000000000..eb9fc16a93eb
--- /dev/null
+++ b/ftp/ncftp3/files/patch-pref.h
@@ -0,0 +1,17 @@
+--- ncftp/pref.h.orig Sun Apr 15 19:36:00 2001
++++ ncftp/pref.h Tue May 8 13:42:15 2001
+@@ -16,10 +16,10 @@
+ # define kFirstFileName "init_v3.txt"
+ #else
+ # define kFirewallPrefFileName "firewall"
+-# define kGlobalFirewallPrefFileName "/etc/ncftp.firewall"
+-# define kGlobalFixedFirewallPrefFileName "/etc/ncftp.firewall.fixed"
+-# define kGlobalPrefFileName "/etc/ncftp.prefs_v3"
+-# define kGlobalFixedPrefFileName "/etc/ncftp.prefs_v3.fixed"
++# define kGlobalFirewallPrefFileName SYSCONFDIR "/ncftp.firewall"
++# define kGlobalFixedFirewallPrefFileName SYSCONFDIR "/ncftp.firewall.fixed"
++# define kGlobalPrefFileName SYSCONFDIR "/ncftp.prefs_v3"
++# define kGlobalFixedPrefFileName SYSCONFDIR "/ncftp.prefs_v3.fixed"
+ # define kPrefFileName "prefs_v3"
+ # define kPrefFileNameV2 "prefs"
+ # define kFirstFileName "init_v3"
diff --git a/ftp/ncftp3/files/patch-sh_util-Makefile.in b/ftp/ncftp3/files/patch-sh_util-Makefile.in
new file mode 100644
index 000000000000..3f8f7069db93
--- /dev/null
+++ b/ftp/ncftp3/files/patch-sh_util-Makefile.in
@@ -0,0 +1,18 @@
+--- sh_util/Makefile.in.orig Fri Dec 8 23:11:25 2000
++++ sh_util/Makefile.in Tue May 8 13:42:15 2001
+@@ -11,13 +11,14 @@
+ VPATH=@srcdir@
+ CPPFLAGS=@CPPFLAGS@ -I. -I../libncftp -I../Strn -I../sio
+ prefix=@prefix@
++SYSCONFDIR=@sysconfdir@
+
+ LIBS=@LIBS@
+ STRIP=strip
+ LDFLAGS=-L../libncftp -L../Strn -L../sio @LDFLAGS@
+
+ # Any -D definitions:
+-DEFS=-Dsh_util @DEFS@
++DEFS=-Dsh_util -DSYSCONFDIR=\"$(SYSCONFDIR)\" @DEFS@
+
+ DPROGS=../bin/ncftpget@EXEEXT@ ../bin/ncftpput@EXEEXT@ ../bin/ncftpbatch@EXEEXT@ ../bin/ncftpls@EXEEXT@
+
diff --git a/ftp/ncftp3/files/patch-vis-Makefile.in b/ftp/ncftp3/files/patch-vis-Makefile.in
new file mode 100644
index 000000000000..abf076a83b72
--- /dev/null
+++ b/ftp/ncftp3/files/patch-vis-Makefile.in
@@ -0,0 +1,19 @@
+--- vis/Makefile.in.orig Wed Apr 11 17:30:13 2001
++++ vis/Makefile.in Tue May 8 13:42:15 2001
+@@ -13,6 +13,7 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ BINDIR=@bindir@
++SYSCONFDIR=@sysconfdir@
+
+ CURSESLIBS=@LIBCURSES@
+ LIBS=$(CURSESLIBS) @LIBS@
+@@ -20,7 +21,7 @@
+ LDFLAGS=-L../libncftp -L../Strn -L../sio @LDFLAGS@
+
+ # Any -D definitions:
+-DEFS=-Dvis -DNCFTPPATH=\"$(BINDIR)/ncftp\" @DEFS@
++DEFS=-Dvis -DNCFTPPATH=\"$(BINDIR)/ncftp\" -DSYSCONFDIR=\"$(SYSCONFDIR)\" @DEFS@
+
+ DPROGS=@VIS_DPROGS@
+
diff --git a/ftp/ncftp3/pkg-comment b/ftp/ncftp3/pkg-comment
index 74f015677bfd..80b124dc8e03 100644
--- a/ftp/ncftp3/pkg-comment
+++ b/ftp/ncftp3/pkg-comment
@@ -1 +1 @@
-FTP replacement with advanced user interface
+ftp replacement with advanced user interface
diff --git a/ftp/ncftp3/pkg-descr b/ftp/ncftp3/pkg-descr
index f57dd5cbd429..69a1f768ddf1 100644
--- a/ftp/ncftp3/pkg-descr
+++ b/ftp/ncftp3/pkg-descr
@@ -1,5 +1,11 @@
- NcFTP is a user interface to the Internet standard File
- Transfer Protocol. This program allows a user to transfer
- files to and from a remote network site, and offers addi-
- tional features that are not found in the standard inter-
- face, ftp.
+NcFTP is a free set of programs that use the File Transfer Protocol.
+The main program is simply called "ncftp". There are also separate
+utility programs for one-shot FTP operations (i.e. for shell scripts
+and command line junkies); these include "ncftpget", "ncftpput",
+and "ncftpls". Also included is a batch processing daemon,
+"ncftpbatch", which is invoked by the "bgget" command from "ncftp"
+and also the "-b" flag of "ncftpput" and "ncftpget". Lastly, the
+"ncftpbookmarks" program is a full-screen utility program to
+manipulate user's FTP bookmarks.
+
+WWW: http://www.ncftp.com/ncftp/