aboutsummaryrefslogtreecommitdiff
path: root/ftp/ncftpd/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-02-21 10:22:48 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-02-21 10:22:48 +0000
commit5b09fe91a35985fdacde7ac24c846fd69a850f41 (patch)
treeaaf3be1bdd926f2f7972dc7111e16ccb1594e6c7 /ftp/ncftpd/Makefile
parent2cc1a417987b0f169216e546245d7b5a97885c27 (diff)
- Add support for FreeBSD 6.x precompiled binaries
- Add one official mirror - portlint - Take maintainership PR: ports/93600 Submitted by: Rainer Alves <rainer.alves@gmail.com>
Notes
Notes: svn path=/head/; revision=156571
Diffstat (limited to 'ftp/ncftpd/Makefile')
-rw-r--r--ftp/ncftpd/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/ftp/ncftpd/Makefile b/ftp/ncftpd/Makefile
index bf24c286fdb9..22308ef317f2 100644
--- a/ftp/ncftpd/Makefile
+++ b/ftp/ncftpd/Makefile
@@ -8,10 +8,11 @@
PORTNAME= ncftpd
PORTVERSION= 2.8.2
CATEGORIES= ftp
-MASTER_SITES= ftp://ftp.ncftp.com/ncftpd/${PORTVERSION}/
+MASTER_SITES= ftp://ftp.ncftp.com/ncftpd/${PORTVERSION}/ \
+ ftp://ftp.nl.uu.net/pub/unix/ftp/ncftpd/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd${BINVER}-${ARCH}-export
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= rainer.alves@gmail.com
COMMENT= A well known commercial FTP daemon with a 30-day evaluation license
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -19,16 +20,18 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
ONLY_FOR_ARCHS= i386
NO_BUILD= YES
LICENSE= shareware
-RESTRICTED= "30 day evaluation license"
+RESTRICTED= 30 day evaluation license
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500000
+.if ${OSVERSION} >= 600000
+BINVER= 6.0
+.elif ${OSVERSION} >= 500000
BINVER= 5.3
.elif ${OSVERSION} >= 480000
BINVER= 4.8
.else
-BROKEN= "FreeBSD version too old"
+BROKEN= FreeBSD version too old
.endif
do-install: