aboutsummaryrefslogtreecommitdiff
path: root/ftp/p5-Net-FTPServer/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-08-23 22:42:51 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-08-23 22:42:51 +0000
commit7da6109ab707cf9e651f1c5d76c54970e9431f51 (patch)
tree9029a02534883d5aae919abf2b439a9b7fc34bd2 /ftp/p5-Net-FTPServer/Makefile
parent76b8f0eb2debbb3360be6f45f5d76911dddbeba9 (diff)
downloadports-7da6109ab707cf9e651f1c5d76c54970e9431f51.tar.gz
ports-7da6109ab707cf9e651f1c5d76c54970e9431f51.zip
Notes
Diffstat (limited to 'ftp/p5-Net-FTPServer/Makefile')
-rw-r--r--ftp/p5-Net-FTPServer/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/ftp/p5-Net-FTPServer/Makefile b/ftp/p5-Net-FTPServer/Makefile
index 33aaf7c495d8..913bcbbc4d1b 100644
--- a/ftp/p5-Net-FTPServer/Makefile
+++ b/ftp/p5-Net-FTPServer/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= Net-FTPServer
-PORTVERSION= 1.102
+PORTVERSION= 1.111
CATEGORIES= ftp perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Net
@@ -22,9 +22,12 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Authen/PAM.pm:${PORTSDIR}/security/p5-A
${SITE_PERL}/${PERL_ARCH}/File/Sync.pm:${PORTSDIR}/devel/p5-File-Sync \
${SITE_PERL}/${PERL_ARCH}/IO/Dir.pm:${PORTSDIR}/devel/p5-IO \
${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy \
- ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip
+ ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
+ ${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_REINPLACE= yes
+MAKE_ENV+= NOCONF=1
SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
PERL_CONFIGURE= yes
@@ -47,8 +50,15 @@ MAN3= Net::FTPServer.3 \
Net::FTPServer::RO::FileHandle.3 \
Net::FTPServer::RO::Server.3
+post-patch:
+ @${REINPLACE_CMD} -e "s/root,root/root,wheel/" \
+ -e "s,/usr/sbin,${PREFIX}/sbin," \
+ ${WRKSRC}/Net-FTPServer.spec.PL
+ @${REINPLACE_CMD} -e "s/-g root/-g wheel/" \
+ -e "s,/usr/sbin,${PREFIX}/sbin," \
+ ${WRKSRC}/Makefile.PL
+
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/ftpd ${PREFIX}/sbin/perlftpd
@${MKDIR} ${PREFIX}/share/examples/Net-FTPServer
${INSTALL_DATA} ${WRKSRC}/ftpd.conf \
${PREFIX}/share/examples/Net-FTPServer