aboutsummaryrefslogtreecommitdiff
path: root/ftp/php5-curl
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2006-12-13 12:41:35 +0000
committerPeter Pentchev <roam@FreeBSD.org>2006-12-13 12:41:35 +0000
commit64e068d25c1370f67d2f0d779ac1719f9bc5d137 (patch)
treee8e79d2b112a29862848aa733e4b3f9387c78d2e /ftp/php5-curl
parent68ee2dd59c7dc7173d1688b825cc1c5a70f097c1 (diff)
Notes
Diffstat (limited to 'ftp/php5-curl')
-rw-r--r--ftp/php5-curl/Makefile2
-rw-r--r--ftp/php5-curl/files/patch-interface.c48
2 files changed, 50 insertions, 0 deletions
diff --git a/ftp/php5-curl/Makefile b/ftp/php5-curl/Makefile
index d9da384a99f0..08eed1c64df6 100644
--- a/ftp/php5-curl/Makefile
+++ b/ftp/php5-curl/Makefile
@@ -11,4 +11,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php5
PKGNAMESUFFIX= -curl
+PORTREVISION= 1
+
.include "${MASTERDIR}/Makefile"
diff --git a/ftp/php5-curl/files/patch-interface.c b/ftp/php5-curl/files/patch-interface.c
new file mode 100644
index 000000000000..e645cd481d30
--- /dev/null
+++ b/ftp/php5-curl/files/patch-interface.c
@@ -0,0 +1,48 @@
+--- interface.c.orig Tue Dec 5 16:50:11 2006
++++ interface.c Tue Dec 5 16:50:25 2006
+@@ -369,7 +369,9 @@
+ REGISTER_CURL_CONSTANT(CURLOPT_FTPAPPEND);
+ REGISTER_CURL_CONSTANT(CURLOPT_NETRC);
+ REGISTER_CURL_CONSTANT(CURLOPT_FOLLOWLOCATION);
++#if CURLOPT_FTPASCII != 0
+ REGISTER_CURL_CONSTANT(CURLOPT_FTPASCII);
++#endif
+ REGISTER_CURL_CONSTANT(CURLOPT_PUT);
+ #if CURLOPT_MUTE != 0
+ REGISTER_CURL_CONSTANT(CURLOPT_MUTE);
+@@ -409,7 +411,9 @@
+ REGISTER_CURL_CONSTANT(CURLOPT_FILETIME);
+ REGISTER_CURL_CONSTANT(CURLOPT_WRITEFUNCTION);
+ REGISTER_CURL_CONSTANT(CURLOPT_READFUNCTION);
++#if CURLOPT_PASSWDFUNCTION != 0
+ REGISTER_CURL_CONSTANT(CURLOPT_PASSWDFUNCTION);
++#endif
+ REGISTER_CURL_CONSTANT(CURLOPT_HEADERFUNCTION);
+ REGISTER_CURL_CONSTANT(CURLOPT_MAXREDIRS);
+ REGISTER_CURL_CONSTANT(CURLOPT_MAXCONNECTS);
+@@ -1158,11 +1162,13 @@
+ dupch->handlers->read->fp = ch->handlers->read->fp;
+ dupch->handlers->read->fd = ch->handlers->read->fd;
+
++#if CURLOPT_PASSWDFUNCTION != 0
+ if (ch->handlers->passwd) {
+ zval_add_ref(&ch->handlers->passwd);
+ dupch->handlers->passwd = ch->handlers->passwd;
+ curl_easy_setopt(ch->cp, CURLOPT_PASSWDDATA, (void *) dupch);
+ }
++#endif
+ if (ch->handlers->write->func_name) {
+ zval_add_ref(&ch->handlers->write->func_name);
+ dupch->handlers->write->func_name = ch->handlers->write->func_name;
+@@ -1915,9 +1921,11 @@
+ if (ch->handlers->write_header->func_name) {
+ zval_ptr_dtor(&ch->handlers->write_header->func_name);
+ }
++#if CURLOPT_PASSWDFUNCTION != 0
+ if (ch->handlers->passwd) {
+ zval_ptr_dtor(&ch->handlers->passwd);
+ }
++#endif
+ if (ch->header.str_len > 0) {
+ efree(ch->header.str);
+ }