aboutsummaryrefslogtreecommitdiff
path: root/ftp/proftpd-devel/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-02-27 07:39:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-02-27 07:39:18 +0000
commit8578d19196c02a32c1ee533f35d84f9acde5ae7a (patch)
tree03d767e4878930f144ffd397518c3ef681cfeafd /ftp/proftpd-devel/Makefile
parenta3afe3e0f63015432ce9e9d9a8c93c89d26b7287 (diff)
downloadports-8578d19196c02a32c1ee533f35d84f9acde5ae7a.tar.gz
ports-8578d19196c02a32c1ee533f35d84f9acde5ae7a.zip
Notes
Diffstat (limited to 'ftp/proftpd-devel/Makefile')
-rw-r--r--ftp/proftpd-devel/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/ftp/proftpd-devel/Makefile b/ftp/proftpd-devel/Makefile
index 0ca2dce1ac19..18749786619f 100644
--- a/ftp/proftpd-devel/Makefile
+++ b/ftp/proftpd-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.1rc2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
@@ -32,8 +32,8 @@ PORTDOCS= ${PORTDOCSdoc} ${PORTDOCScontrib}
USE_GMAKE= yes
USE_BZIP2= yes
-USE=AUTOTOOLS= autoconf:259
-GNU_CONFIGURE=yes
+USE_AUTOTOOLS= autoconf:259
+GNU_CONFIGURE= yes
USE_RC_SUBR= proftpd.sh
@@ -59,7 +59,9 @@ OPTIONS= IPV6 "Use IPv6" off \
RADIUS "Include mod_radius" off \
QUOTATAB_RADIUS "include mod_quotatab_radius" off \
BAN "include mod_ban (Requires CTRLS)" off \
- NLS "Use nls (builds mod_lang)" off
+ NLS "Use nls (builds mod_lang)" off \
+ CYRFIX "Use patch for fix cyrillic encoding" off \
+ CODECONV "Use charset conversion (mod_codeconv)" off
MODULES?=
LIBDIRS?=
@@ -67,11 +69,6 @@ INCLUDEDIRS?=
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-CONFIGURE_ARGS+= --without-getopt
-USE_AUTOTOOLS= autoconf:259
-.endif
-
.if !defined(WITHOUT_RATIO)
MODULES:=${MODULES}:mod_ratio
.endif
@@ -139,6 +136,10 @@ PROFTPD_LIBS+= -lintl -L${LOCALBASE}/lib
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-nls-Makefile.in
.endif
+.if defined (WITH_CYRFIX)
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-cyrillic-fix-netio.c
+.endif
+
#allow user to override
MODULES?= mod_ratio:mod_readme:mod_rewrite:mod_wrap2:mod_ifsession
@@ -197,6 +198,12 @@ MODULES:=${MODULES}:mod_quotatab_sql
.endif
.endif
+.if defined(WITH_CODECONV)
+MODULES:=${MODULES}:mod_codeconv
+PROFTPD_LIBS+= -liconv -L${LOCALBASE}/lib
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-mod-codeconv
+.endif
+
# mod_ifsession should be the last item in the modules list
.if !defined(WITHOUT_IFSESSION)
MODULES:=${MODULES}:mod_ifsession