aboutsummaryrefslogtreecommitdiff
path: root/ftp/proftpd/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2017-07-27 15:25:30 +0000
committerMartin Matuska <mm@FreeBSD.org>2017-07-27 15:25:30 +0000
commit038563bcf2b2dbb16647977bad1c84b4b0e9b720 (patch)
treece7037c0af8d842aa3b4f0d197b048d94ae6bcd1 /ftp/proftpd/Makefile
parent4e72deff0546982f5359e09ff819c54d8edafcd0 (diff)
Notes
Diffstat (limited to 'ftp/proftpd/Makefile')
-rw-r--r--ftp/proftpd/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 64ebd0f4feaa..76bc362f960a 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -26,7 +26,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/sbin/proftpd:ftp/proftpd
RUN_DEPENDS+= ${LOCALBASE}/sbin/proftpd:ftp/proftpd
.endif
-PROFTPD_VERSION= 1.3.5e
+PROFTPD_VERSION= 1.3.6
.if defined(_BUILDING_PROFTPD_MODULE)
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX}
@@ -86,11 +86,12 @@ PLIST_FILES+= libexec/proftpd/${m}.a \
libexec/proftpd/${m}.so
.endfor
.else
-OPTIONS_DEFINE= DOCS HTMLDOCS IPV6 NLS MEMCACHE PCRE
+OPTIONS_DEFINE= DOCS HTMLDOCS IPV6 NLS MEMCACHE PCRE REDIS
OPTIONS_DEFAULT= PCRE
HTMLDOCS_DESC= Include HTML documentation
MEMCACHE_DESC= Memcache support using libmemcached
+REDIS_DESC= Redis support using hiredis
PLIST_SUB+= LOCALSTATEDIR="${LOCALSTATEDIR}"
OPTIONS_SUB= yes
@@ -154,6 +155,11 @@ MEMCACHE_CONFIGURE_ENABLE= memcache
MEMCACHE_VARS= MODULES+="mod_memcache mod_tls_memcache" \
LIBS+="-L${LOCALBASE}/lib -lmemcached -lmemcachedutil"
+REDIS_LIB_DEPENDS= libhiredis.so:databases/hiredis
+REDIS_CONFIGURE_ENABLE= redis
+REDIS_VARS= MODULES+="mod_redis mod_tls_redis mod_wrap2_redis" \
+ LIBS+="-L${LOCALBASE}/lib -lhiredis"
+
.include <bsd.port.options.mk>
# Generate modules configuration string