aboutsummaryrefslogtreecommitdiff
path: root/ftp/proftpd/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2014-03-15 16:28:07 +0000
committerMartin Matuska <mm@FreeBSD.org>2014-03-15 16:28:07 +0000
commit08b8acf316934a1070cfb81ebf6b74ba999466ee (patch)
tree9debed8e811394049cffd27d24080581a48a0172 /ftp/proftpd/Makefile
parent6afa1e436bc49b7ca2aafe307510a5147fb72d24 (diff)
downloadports-08b8acf316934a1070cfb81ebf6b74ba999466ee.tar.gz
ports-08b8acf316934a1070cfb81ebf6b74ba999466ee.zip
Notes
Diffstat (limited to 'ftp/proftpd/Makefile')
-rw-r--r--ftp/proftpd/Makefile25
1 files changed, 6 insertions, 19 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index db581bd349ae..7de664eeb816 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -3,13 +3,12 @@
PORTNAME?= proftpd
PORTVERSION?= 1.3.4d
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES?= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
https://github.com/downloads/proftpd/proftpd.github.com/ \
ftp://proftpd.networkedsystems.co.uk/distrib/source/ \
- http://www.mirrorservice.org/sites/ftp.proftpd.org/distrib/source/ \
- https://codeload.github.com/jbenden/mod_clamav/legacy.tar.gz/v0.13rc2?dummy=/:clamav
+ http://www.mirrorservice.org/sites/ftp.proftpd.org/distrib/source/
.if defined(_BUILDING_PROFTPD_MODULE)
DISTNAME= proftpd-${PORTVERSION}
.endif
@@ -35,6 +34,9 @@ EXTRACT_ONLY+= ${_PROFTPD_MODULE_EXTRACT_ONLY}
. if defined(_PROFTPD_MODULE_DISTFILES)
DISTFILES+= ${_PROFTPD_MODULE_DISTFILES}
. endif
+. if defined(_PROFTPD_MODULE_MASTER_SITES)
+MASTER_SITES+= ${_PROFTPD_MODULE_MASTER_SITES}
+. endif
.endif
.if !defined(_BUILDING_PROFTPD_MODULE)
@@ -79,10 +81,9 @@ PLIST_FILES+= libexec/proftpd/${m}.a \
.endfor
PLIST_DIRSTRY+= libexec/proftpd
.else
-OPTIONS_DEFINE= HTMLDOCS IPV6 NLS MEMCACHE PCRE CLAMAV
+OPTIONS_DEFINE= HTMLDOCS IPV6 NLS MEMCACHE PCRE
OPTIONS_DEFAULT= IPV6 NLS PCRE
-CLAMAV_DESC= Include mod_clamav
HTMLDOCS_DESC= Include HTML documentation
MEMCACHE_DESC= Memcache support using libmemcached
@@ -167,17 +168,6 @@ CONFIGURE_ARGS+= --enable-pcre
CONFIGURE_ARGS+= --disable-pcre
.endif
-.if ${PORT_OPTIONS:MCLAMAV} || make(makesum) || defined(FETCH_ALL)
-DISTFILES+= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
- mod_clamav-v0.13rc2${EXTRACT_SUFX}:clamav
-USE_CLAMAV= yes
-MODULES+= mod_clamav
-RUN_DEPENDS+= clamd:${PORTSDIR}/security/clamav
-PLIST_SUB+= CLAMAV=""
-.else
-PLIST_SUB+= CLAMAV="@comment "
-.endif
-
.if ${PORT_OPTIONS:MMEMCACHE}
MODULES+= mod_memcache \
mod_tls_memcache
@@ -213,9 +203,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|proftpd\.conf|proftpd.conf.sample|g' ${WRKSRC}/Makefile.in
pre-configure:
-.if ${PORT_OPTIONS:MCLAMAV}
- @${CP} ${WRKDIR}/jbenden-mod_clamav-0b524e3/mod_clamav.* ${WRKSRC}/contrib
-.endif
@${ECHO_MSG} "==> Configuring with following modules:"
@${ECHO_MSG} "${MODULES:C/^://g}"