aboutsummaryrefslogtreecommitdiff
path: root/ftp/proftpd/Makefile
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2001-08-17 19:00:51 +0000
committerMichael Haro <mharo@FreeBSD.org>2001-08-17 19:00:51 +0000
commitc5dd75d3d2559227f1d860746afd8321dc74b097 (patch)
tree4d9ea58297daacde03f96f26c3695da1d4c42858 /ftp/proftpd/Makefile
parentcd8fb9d41a171c9f54fc7d5867eb64a4c251fd26 (diff)
Notes
Diffstat (limited to 'ftp/proftpd/Makefile')
-rw-r--r--ftp/proftpd/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index aead5ddece39..c2c1f2aa12c1 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= proftpd
-PORTVERSION= 1.2.2rc3
+PORTVERSION= 1.2.2
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.net/distrib/source/ \
ftp://ftp.stikman.com/pub/proftpd/source/ \
@@ -50,6 +50,13 @@ INCLUDEDIRS:=${INCLUDEDIRS}:${PREFIX}/include
LIBDIRS:=${LIBDIRS}:${PREFIX}/lib/mysql
.endif
+.if defined(WITH_POSTGRES)
+MODULES:=${MODULES}:mod_sql:mod_sql_postgres
+LIB_DEPENDS+= pq.2:\${PORTSDIR}/databases/postgresql7
+INCLUDEDIRS:=${INCLUDEDIRS}:${PREFIX}/include/pgsql
+LIBDIRS:=${LIBDIRS}:${PREFIX}/lib
+.endif
+
.if !empty(MODULES)
CONFIGURE_ARGS+= --with-modules=${MODULES}
.endif