aboutsummaryrefslogtreecommitdiff
path: root/ftp/proftpd
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2004-12-14 06:16:43 +0000
committerMichael Haro <mharo@FreeBSD.org>2004-12-14 06:16:43 +0000
commit2b4140ad3ad2b0153d0c1799bf88c8237f33e1fa (patch)
tree53240fdf81b87d97c1d53c45efa4abe05cbd96d7 /ftp/proftpd
parent17a05ac8c02dfe347d1213c742b0186620139f16 (diff)
downloadports-2b4140ad3ad2b0153d0c1799bf88c8237f33e1fa.tar.gz
ports-2b4140ad3ad2b0153d0c1799bf88c8237f33e1fa.zip
Notes
Diffstat (limited to 'ftp/proftpd')
-rw-r--r--ftp/proftpd/Makefile44
1 files changed, 41 insertions, 3 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 3ad3221d9132..f9f77f0d9070 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= proftpd
PORTVERSION= 1.2.10
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
@@ -48,6 +48,42 @@ PLIST_SUB+= RC_DIR=${RC_DIR} \
CONFIGURE_ARGS= --localstatedir=/var/run \
--disable-sendfile
+OPTIONS= IPV6 "Use IPv6" off \
+ LDAP "Use LDAP" off \
+ MYSQL "Use MySQL" off \
+ POSTGRESQL "Use Postgres" off \
+ OPENSSL "Include mod_tls" off \
+ QUOTA "Include mod_quota" off \
+ IFSESSION "Include mod_ifsession" on \
+ README "Include mod_readme" on \
+ RATIO "Include mod_ratio" on \
+ REWRITE "Include mod_rewrite" on \
+ WRAP "Include mod_wrap" on
+
+MODULES?=
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_IFSESSION)
+MODULES:=${MODULES}:mod_ifsession
+.endif
+
+.if defined(WITH_RATIO)
+MODULES:=${MODULES}:mod_ratio
+.endif
+
+.if defined(WITH_README)
+MODULES:=${MODULES}:mod_readme
+.endif
+
+.if defined(WITH_REWRITE)
+MODULES:=${MODULES}:mod_rewrite
+.endif
+
+.if defined(WITH_WRAP)
+MODULES:=${MODULES}:mod_wrap
+.endif
+
.if defined(WITH_SETPASSENT)
CONFIGURE_ARGS+= --enable-force-setpassent
.endif
@@ -65,7 +101,7 @@ CONFIGURE_ARGS+= --disable-ipv6
.endif
#allow user to override
-MODULES?= mod_ratio:mod_readme:mod_wrap
+MODULES?= mod_ifsession:mod_ratio:mod_readme:mod_rewrite:mod_wrap
INCLUDEDIRS=
LIBDIRS=
@@ -134,6 +170,8 @@ CONFIGURE_ARGS+= --with-includes=${INCLUDEDIRS}
CONFIGURE_ARGS+= --with-libraries=${LIBDIRS}
.endif
+MODULES!=${ECHO} ${MODULES} | ${SED} -e 's,^:,,' -e 's,:$$,,'
+
pre-configure:
@${ECHO_MSG} "==> Configuring with ${MODULES}"
@@ -194,4 +232,4 @@ do-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>