aboutsummaryrefslogtreecommitdiff
path: root/ftp/profxp
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-13 14:46:54 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-13 14:46:54 +0000
commit5f187cf3b282607c82a5d1dc492268326f9ddd5a (patch)
tree77c9c1add5a1a139738b019d7540267d0850073c /ftp/profxp
parent6e24cd87446681e79d145bad2c86cc19a1afcf1c (diff)
downloadports-5f187cf3b282607c82a5d1dc492268326f9ddd5a.tar.gz
ports-5f187cf3b282607c82a5d1dc492268326f9ddd5a.zip
Notes
Diffstat (limited to 'ftp/profxp')
-rw-r--r--ftp/profxp/Makefile28
-rw-r--r--ftp/profxp/distinfo1
-rw-r--r--ftp/profxp/pkg-comment1
-rw-r--r--ftp/profxp/pkg-descr7
-rw-r--r--ftp/profxp/pkg-plist1
5 files changed, 38 insertions, 0 deletions
diff --git a/ftp/profxp/Makefile b/ftp/profxp/Makefile
new file mode 100644
index 000000000000..0fd73cc3fd9d
--- /dev/null
+++ b/ftp/profxp/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: profxp
+# Date created: Jun 1, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= profxp
+PORTVERSION= 2p1
+CATEGORIES= ftp
+MASTER_SITES= http://duncanthrax.net/profxp/
+DISTNAME= ${PORTNAME}.v${PORTVERSION:S/p/-pre/}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/SOCKS.pm:${PORTSDIR}/net/p5-Socks \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Term/ReadLine/Perl.pm:${PORTSDIR}/devel/p5-ReadLine-Perl \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/profxpv2.pl ${PREFIX}/bin/profxp
+
+.include <bsd.port.mk>
diff --git a/ftp/profxp/distinfo b/ftp/profxp/distinfo
new file mode 100644
index 000000000000..9418743a085c
--- /dev/null
+++ b/ftp/profxp/distinfo
@@ -0,0 +1 @@
+MD5 (profxp.v2-pre1.tar.gz) = 9f050b7e1248941f54bcec0fc095aa20
diff --git a/ftp/profxp/pkg-comment b/ftp/profxp/pkg-comment
new file mode 100644
index 000000000000..f1aae732947c
--- /dev/null
+++ b/ftp/profxp/pkg-comment
@@ -0,0 +1 @@
+FXP (server-to-server FTP) client
diff --git a/ftp/profxp/pkg-descr b/ftp/profxp/pkg-descr
new file mode 100644
index 000000000000..b1173fcf2726
--- /dev/null
+++ b/ftp/profxp/pkg-descr
@@ -0,0 +1,7 @@
+proFXP is a FXP (server-to-server FTP) client written in Perl. It features
+TAB completion, site management, idle timers, SOCKS support, active and
+passive mode, different listing modes and a very powerful "down-to-the
+protocol metal" 2-char-command command line interface, pleasing newbies and
+hardcore hackers alike.
+
+WWW: http://duncanthrax.net/profxp/
diff --git a/ftp/profxp/pkg-plist b/ftp/profxp/pkg-plist
new file mode 100644
index 000000000000..47ec0b70ac43
--- /dev/null
+++ b/ftp/profxp/pkg-plist
@@ -0,0 +1 @@
+bin/profxp