aboutsummaryrefslogtreecommitdiff
path: root/ftp/prozilla/Makefile
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2003-04-19 21:06:54 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2003-04-19 21:06:54 +0000
commit682c399f7c51aaf141976705010f4faf2aa5176d (patch)
tree8e7c7b569f0749b9cbb5ff8d876ee1459f5828b9 /ftp/prozilla/Makefile
parenta22769375b7a96ead063f4449b8550b84f6d97f2 (diff)
downloadports-682c399f7c51aaf141976705010f4faf2aa5176d.tar.gz
ports-682c399f7c51aaf141976705010f4faf2aa5176d.zip
Notes
Diffstat (limited to 'ftp/prozilla/Makefile')
-rw-r--r--ftp/prozilla/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/ftp/prozilla/Makefile b/ftp/prozilla/Makefile
new file mode 100644
index 000000000000..c632a0c7502e
--- /dev/null
+++ b/ftp/prozilla/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: ftp/prozilla
+# Date created: Jan 24 2003
+# Whom: Juan Salaverria <rael@vectorstar.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= prozilla
+PORTVERSION= 1.3.6
+CATEGORIES= ftp
+MASTER_SITES= http://prozilla.genesys.ro/downloads/prozilla/tarballs/
+
+MAINTAINER= rael@vectorstar.net
+COMMENT= ProZilla is a fast download accelerator
+
+LIB_DEPENDS= ncurses.5:${PORTSDIR}/devel/ncurses \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+
+MAN1= proz.1 prozilla.1
+
+DOCS= ANNOUNCE AUTHORS COPYING CREDITS ChangeLog INSTALL FAQ NEWS README TODO
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>