aboutsummaryrefslogtreecommitdiff
path: root/ftp/prozilla
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-02-15 07:49:32 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-02-15 07:49:32 +0000
commit96c6b14baa9ab7a981656ea025faf42fa20c86fe (patch)
tree0287bcc7acb5d5836262751844dec4296aad225f /ftp/prozilla
parent6d04ba603f158cff9df737525d4a62863d34e8ab (diff)
downloadports-96c6b14baa9ab7a981656ea025faf42fa20c86fe.tar.gz
ports-96c6b14baa9ab7a981656ea025faf42fa20c86fe.zip
Notes
Diffstat (limited to 'ftp/prozilla')
-rw-r--r--ftp/prozilla/Makefile12
-rw-r--r--ftp/prozilla/files/patch-libprozilla_src_Makefile.in24
-rw-r--r--ftp/prozilla/files/pkg-message.in11
-rw-r--r--ftp/prozilla/pkg-descr23
-rw-r--r--ftp/prozilla/pkg-plist7
5 files changed, 51 insertions, 26 deletions
diff --git a/ftp/prozilla/Makefile b/ftp/prozilla/Makefile
index a7bbb175d817..40147f24e1e6 100644
--- a/ftp/prozilla/Makefile
+++ b/ftp/prozilla/Makefile
@@ -7,8 +7,8 @@
PORTNAME= prozilla
PORTVERSION= 2.0.3
-PORTREVISION= 1
-CATEGORIES= ftp
+PORTREVISION= 2
+CATEGORIES= ftp net
MASTER_SITES= http://prozilla.genesys.ro/downloads/prozilla/tarballs/
MAINTAINER= alejandro@varnet.biz
@@ -26,4 +26,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= proz.1
+SUB_FILES= pkg-message
+PKGMESSAGE= ${FILESDIR}/pkg-message
+
+post-install:
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
.include <bsd.port.mk>
diff --git a/ftp/prozilla/files/patch-libprozilla_src_Makefile.in b/ftp/prozilla/files/patch-libprozilla_src_Makefile.in
index 4616b2f445d4..152ae5d86223 100644
--- a/ftp/prozilla/files/patch-libprozilla_src_Makefile.in
+++ b/ftp/prozilla/files/patch-libprozilla_src_Makefile.in
@@ -1,11 +1,17 @@
--- libprozilla/src/Makefile.in.orig Sun Dec 11 21:19:15 2005
-+++ libprozilla/src/Makefile.in Thu Jan 19 17:11:36 2006
-@@ -114,7 +114,7 @@
- # example...)
- libprozilla_la_LDFLAGS = -version-info 1:0:1
++++ libprozilla/src/Makefile.in Sun Feb 12 20:29:58 2006
+@@ -226,11 +226,11 @@
--include_HEADERS = prozilla.h common.h netrc.h
-+include_HEADERS = prozilla.h netrc.h
- CPPFLAGS = @CPPFLAGS@ -DLOCALEDIR=\"$(datadir)/locale\"
- INCLUDES = -I../intl -I@includedir@
- #AM_CPPFLAGS = -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+ install-includeHEADERS: $(include_HEADERS)
+ @$(NORMAL_INSTALL)
+- $(mkinstalldirs) $(DESTDIR)$(includedir)
++ $(mkinstalldirs) $(DESTDIR)$(includedir)/prozilla
+ @list='$(include_HEADERS)'; for p in $$list; do \
+ if test -f "$$p"; then d= ; else d="$(srcdir)/"; fi; \
+- echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(includedir)/$$p"; \
+- $(INSTALL_DATA) $$d$$p $(DESTDIR)$(includedir)/$$p; \
++ echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(includedir)/prozilla/$$p"; \
++ $(INSTALL_DATA) $$d$$p $(DESTDIR)$(includedir)/prozilla/$$p; \
+ done
+
+ uninstall-includeHEADERS:
diff --git a/ftp/prozilla/files/pkg-message.in b/ftp/prozilla/files/pkg-message.in
new file mode 100644
index 000000000000..6b63a128199b
--- /dev/null
+++ b/ftp/prozilla/files/pkg-message.in
@@ -0,0 +1,11 @@
+==============================================================================
+
+ProZilla has been installed!
+
+The libprozilla header files are now installed in a "prozilla" subdirectory to
+avoid problems caused by the file named "common.h".
+
+Now to compile a program that uses libprozilla you have to add the
+"-I%%PREFIX%%/include/prozilla" flag to the compiler.
+
+==============================================================================
diff --git a/ftp/prozilla/pkg-descr b/ftp/prozilla/pkg-descr
index 4878e1a1ce6c..910bf43b785b 100644
--- a/ftp/prozilla/pkg-descr
+++ b/ftp/prozilla/pkg-descr
@@ -1,17 +1,16 @@
-ProZilla is a download accelerator for Linux which gives you
-a 200% to 300% improvement in your file downloading speeds.
+ProZilla is a download accelerator for Linux which gives you a 200% to 300%
+improvement in your file downloading speeds.
Its features:
- * Supports FTP & HTTP including redirection
- * Resume Supported
- * Complete acceleration: The file will be downloaded as fast as
- possible as your bandwidth allows if not otherwise specified
- * Unlike certain other download accelerators available for Linux,
- this really works.
- * The number of connections that prozilla uses can be specified
- * FTPsearch support now permits fetching Mirror locations and
- pinging them and selecting the fastest server is automatically
- done
+* Supports FTP & HTTP including redirection.
+* Resume Supported.
+* Complete acceleration: The file will be downloaded as fast as possible as
+ your bandwidth allows if not otherwise specified.
+* Unlike certain other download accelerators available for Linux, this really
+ works.
+* The number of connections that prozilla uses can be specified.
+* FTPsearch support now permits fetching Mirror locations and pinging them and
+ selecting the fastest server is automatically done.
WWW: http://prozilla.genesys.ro/
diff --git a/ftp/prozilla/pkg-plist b/ftp/prozilla/pkg-plist
index 859e84a3ba06..70ed10e8ee36 100644
--- a/ftp/prozilla/pkg-plist
+++ b/ftp/prozilla/pkg-plist
@@ -1,7 +1,7 @@
bin/proz
-@comment include/common.h
-include/netrc.h
-include/prozilla.h
+include/prozilla/common.h
+include/prozilla/netrc.h
+include/prozilla/prozilla.h
lib/libprozilla.a
share/locale/fr/LC_MESSAGES/proz.mo
share/locale/it/LC_MESSAGES/.mo
@@ -12,3 +12,4 @@ share/locale/pt_BR/LC_MESSAGES/.mo
share/locale/pt_BR/LC_MESSAGES/proz.mo
share/locale/ro/LC_MESSAGES/.mo
share/locale/ro/LC_MESSAGES/proz.mo
+@dirrm include/prozilla