aboutsummaryrefslogtreecommitdiff
path: root/ftp/pure-ftpd/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-27 18:04:20 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-27 18:04:20 +0000
commit502fcf0fbd85836786d20529819da1fb11a8c3a0 (patch)
treea43ac589ddc24a21892a2cdcfd305d0351824123 /ftp/pure-ftpd/Makefile
parent2766cc9b385490ddc151d6b48620c84e07624cf5 (diff)
Notes
Diffstat (limited to 'ftp/pure-ftpd/Makefile')
-rw-r--r--ftp/pure-ftpd/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/ftp/pure-ftpd/Makefile b/ftp/pure-ftpd/Makefile
index f301b442feba..3502a99ba1e1 100644
--- a/ftp/pure-ftpd/Makefile
+++ b/ftp/pure-ftpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pure-ftpd
PORTVERSION= 1.0.20
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= ftp ipv6
MASTER_SITES= ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/ \
ftp://ftp2.fr.pureftpd.org/pub/mirrors/ftp.fr.pureftpd.org/pub/pure-ftpd/releases/ \
@@ -46,7 +46,8 @@ OPTIONS= LDAP "Support for users in LDAP directories" off \
PRIVSEP "Enable privilege separation" off \
PERUSERLIMITS "Per-user concurrency limits" off \
THROTTLING "Bandwidth throttling" off \
- BANNER "Show ${PORTNAME} welcome upon session start" on
+ BANNER "Show ${PORTNAME} welcome upon session start" on \
+ UPLOADSCRIPT "Support uploadscript daemon" off
.include <bsd.port.pre.mk>
@@ -103,6 +104,11 @@ CONFIGURE_ARGS+= --with-pam
CONFIGURE_ARGS+= --without-banner
.endif
+# support uploadscript?
+.if defined (WITH_UPLOADSCRIPT)
+CONFIGURE_ARGS+= --with-uploadscript
+.endif
+
.if ${OSVERSION} > 500000
PAM_TEMPL?= ${FILESDIR}/pam.conf.5
.else
@@ -158,5 +164,6 @@ post-install:
@${ECHO_MSG} "Now you need to examine ${PAM_DIR}/${PAM_TARGET}"
@${ECHO_MSG} "and add the relevant PAM configuration lines to your /etc/pam.conf file."
.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>