aboutsummaryrefslogtreecommitdiff
path: root/ftp/pure-ftpd
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-24 11:18:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-24 11:18:47 +0000
commitac9d016968b5c64e794d082ee4f964294fc735ef (patch)
tree689e4f20f5d69102fb093e9efb5334823a193296 /ftp/pure-ftpd
parentb2a8b75742951f3d74dada640b09efe96ca6a116 (diff)
downloadports-ac9d016968b5c64e794d082ee4f964294fc735ef.tar.gz
ports-ac9d016968b5c64e794d082ee4f964294fc735ef.zip
Notes
Diffstat (limited to 'ftp/pure-ftpd')
-rw-r--r--ftp/pure-ftpd/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/ftp/pure-ftpd/Makefile b/ftp/pure-ftpd/Makefile
index 8786c0eadd7a..8a92955a2e33 100644
--- a/ftp/pure-ftpd/Makefile
+++ b/ftp/pure-ftpd/Makefile
@@ -41,9 +41,11 @@ MAN8= pure-ftpd.8 pure-ftpwho.8 pure-mrtginfo.8 pure-statsdecode.8 \
OPTIONS= LDAP "Support for users in LDAP directories" off \
MYSQL "Support for users in MySQL database" off \
+ PAM "Support for PAM authentication" on \
PGSQL "Support for users in PostgreSQL database" off \
PRIVSEP "Enable privilege separation" off \
- PERUSERLIMITS "Per-user concurrency limits" off
+ PERUSERLIMITS "Per-user concurrency limits" off \
+ THROTTLING "Bandwidth throttling" off
.include <bsd.port.pre.mk>
@@ -81,13 +83,18 @@ CONFIGURE_ARGS+= --with-privsep
CONFIGURE_ARGS+= --with-peruserlimits
.endif
+# throttling requested?
+.if defined(WITH_THROTTLING)
+CONFIGURE_ARGS+= --with-throttling
+.endif
+
# different certificate file location?
.if defined(WITH_CERTFILE)
CONFIGURE_ARGS+= --with-certfile=${WITH_CERTFILE}
.endif
# if mysql or ldap are disabled, enable pam
-.if !defined(WITH_LDAP) && !defined(WITH_MYSQL) && !defined(WITH_PGSQL)
+.if !defined(WITHOUT_PAM)
CONFIGURE_ARGS+= --with-pam
.endif