aboutsummaryrefslogtreecommitdiff
path: root/ftp/pureadmin/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-26 15:54:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-26 15:54:32 +0000
commitaff1c7581fb56fc2deeb34957161d2d3d5d196dc (patch)
tree4a8d4d8cf366148b74164c2bbd5babc7b73fe090 /ftp/pureadmin/Makefile
parent483b6cbd993a3f056c51a516568bef9825955575 (diff)
Notes
Diffstat (limited to 'ftp/pureadmin/Makefile')
-rw-r--r--ftp/pureadmin/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/ftp/pureadmin/Makefile b/ftp/pureadmin/Makefile
index d9b9d090d74d..6e8b169fe078 100644
--- a/ftp/pureadmin/Makefile
+++ b/ftp/pureadmin/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= pureadmin
-PORTVERSION= 0.2.2
-PORTREVISION= 1
+PORTVERSION= 0.3
CATEGORIES= ftp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= purify
@@ -16,16 +15,18 @@ MASTER_SITE_SUBDIR= purify
MAINTAINER= ports@FreeBSD.org
COMMENT= Management utility for the PureFTPd
-LIB_DEPENDS= fam.0:${PORTSDIR}/devel/fam
-
USE_X_PREFIX= yes
-USE_GNOME= gnomehack gnomeprefix gtk20
+USE_GNOME= gnomehack gnomeprefix libglade2
+USE_FAM= yes
USE_REINPLACE= yes
+INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
post-patch:
- @${REINPLACE_CMD} -e '/-g -Wall/d' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|-std=gnu99||g' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>