aboutsummaryrefslogtreecommitdiff
path: root/ftp/py-pycurl/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-12-07 16:00:23 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-12-07 16:00:23 +0000
commit5f74204fe15b50f03877ece0be89d0c00ac320b6 (patch)
treea82ab161db514d1a97ff246737c36ce7b7aa8123 /ftp/py-pycurl/Makefile
parent31f5998a4cdbd0f6ac492f368fb91ac2c4e9d5b7 (diff)
downloadports-5f74204fe15b50f03877ece0be89d0c00ac320b6.tar.gz
ports-5f74204fe15b50f03877ece0be89d0c00ac320b6.zip
Notes
Diffstat (limited to 'ftp/py-pycurl/Makefile')
-rw-r--r--ftp/py-pycurl/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/ftp/py-pycurl/Makefile b/ftp/py-pycurl/Makefile
index bb22b301a84d..73d26520908b 100644
--- a/ftp/py-pycurl/Makefile
+++ b/ftp/py-pycurl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pycurl
PORTVERSION= 7.43.0
+PORTREVISION= 1
CATEGORIES= ftp python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,10 +18,18 @@ LICENSE_MIT= ${WRKSRC}/COPYING-MIT
LIB_DEPENDS= libcurl.so:ftp/curl
+OPTIONS_DEFINE= DOCS
+
USE_PYTHON= autoplist concurrent distutils
USES= python ssl
+PORTDOCS= AUTHORS INSTALL.rst README.rst RELEASE-NOTES.rst
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}.so
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
+
.include <bsd.port.mk>