aboutsummaryrefslogtreecommitdiff
path: root/ftp/scythia/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-12 17:20:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-12 17:20:48 +0000
commitd3cb3f55807c474278b19d1f71ad04211e2f863e (patch)
treec4be7b7c69189b5db8da19cbf68a3eeb44392f5e /ftp/scythia/Makefile
parent1bdab59a5997b70be324a47b03d861492d2999f2 (diff)
Notes
Diffstat (limited to 'ftp/scythia/Makefile')
-rw-r--r--ftp/scythia/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/ftp/scythia/Makefile b/ftp/scythia/Makefile
new file mode 100644
index 000000000000..9699fcd637f1
--- /dev/null
+++ b/ftp/scythia/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: scythia
+# Date created: 30 Jun 2007
+# Whom: Yinghong.Liu <relaxbsd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scythia
+PORTVERSION= 0.9.1
+CATEGORIES= ftp
+MASTER_SITES= http://scythia.free.fr/file/ \
+ ftp://local-distfiles.freebsd.org.cn/pub/china-ports/hamigua/
+DISTNAME= ${PORTNAME}_${PORTVERSION}-src
+
+MAINTAINER= relaxbsd@gmail.com
+COMMENT= A small ftp client unpretentious based on QT4
+
+USE_QT_VER= 4
+QT_COMPONENTS= gui network corelib qmake uic moc rcc
+INSTALLS_ICONS= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.if defined(NOPORTDOCS)
+INSTALL_TARGET=install_lang install_icon install_icon2 install_desktop install_target
+.endif
+
+DESKTOP_ENTRIES= "Scythia" \
+ "A small ftp client unpretentious" \
+ "scythia" \
+ "scythia" \
+ "Application;Network;" \
+ "false"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g' \
+ -e '/unix:desktop/d' \
+ ${WRKSRC}/scythia.pro
+ @${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g' \
+ ${WRKSRC}/src/main.cpp
+
+pre-build:
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${QMAKE} -unix PREFIX=${PREFIX} scythia.pro
+
+.include <bsd.port.mk>