aboutsummaryrefslogtreecommitdiff
path: root/ftp/vsftpd/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-12-31 07:41:01 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-12-31 07:41:01 +0000
commit4cc160ab2d1b420c40d421484104420190f62076 (patch)
tree3cd1bfc6c459d3d0d7f7e4501e367916b7229c38 /ftp/vsftpd/Makefile
parentf88830c9a62e09743d1e09873fc8b8488414c384 (diff)
downloadports-4cc160ab2d1b420c40d421484104420190f62076.tar.gz
ports-4cc160ab2d1b420c40d421484104420190f62076.zip
Notes
Diffstat (limited to 'ftp/vsftpd/Makefile')
-rw-r--r--ftp/vsftpd/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/ftp/vsftpd/Makefile b/ftp/vsftpd/Makefile
index 3655134039dd..7c641e2bd39f 100644
--- a/ftp/vsftpd/Makefile
+++ b/ftp/vsftpd/Makefile
@@ -56,7 +56,7 @@ VSFTPD_NO_SSP= -e "s|-fstack-protector --param=ssp-buffer-size=4 ||"
.endif
do-configure:
-.if !defined(WITHOUT_SSL) && ${PORT_OPTIONS:MVSFTPD_SSL}
+.if ${PORT_OPTIONS:MVSFTPD_SSL} && !defined(WITHOUT_SSL)
${REINPLACE_CMD} -e \
"s|#undef VSF_BUILD_TCPWRAPPERS|#define VSF_BUILD_TCPWRAPPERS 1|" \
-e "s|#undef VSF_BUILD_SSL|#define VSF_BUILD_SSL 1|" \
@@ -86,14 +86,12 @@ do-configure:
@${ECHO_CMD} >>${WRKSRC}/vsftpd.conf "# listen=YES"
@${ECHO_CMD} >>${WRKSRC}/vsftpd.conf "# background=YES"
-pre-install:
- ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/vsftpd ${STAGEDIR}${PREFIX}/libexec/
${INSTALL_DATA} ${WRKSRC}/vsftpd.conf ${STAGEDIR}${PREFIX}/etc/vsftpd.conf.dist
${INSTALL_MAN} ${WRKSRC}/vsftpd.conf.5 ${STAGEDIR}${MANPREFIX}/man/man5/
${INSTALL_MAN} ${WRKSRC}/vsftpd.8 ${STAGEDIR}${MANPREFIX}/man/man8/
+ ${MKDIR} ${STAGEDIR}/var/ftp
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} -m 644 ${DOCFILES:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/