aboutsummaryrefslogtreecommitdiff
path: root/ftp/wget-devel
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2001-08-09 01:35:56 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2001-08-09 01:35:56 +0000
commitde73824db99e9164d3325bce82266ef4c59c960a (patch)
treeb4749863e7476ed05c9120f42e5b70844dfe1bbd /ftp/wget-devel
parent108b885c032e522b775dd8e45a00339a865a38df (diff)
downloadports-de73824db99e9164d3325bce82266ef4c59c960a.tar.gz
ports-de73824db99e9164d3325bce82266ef4c59c960a.zip
Notes
Diffstat (limited to 'ftp/wget-devel')
-rw-r--r--ftp/wget-devel/Makefile2
-rw-r--r--ftp/wget-devel/files/patch-host.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/ftp/wget-devel/Makefile b/ftp/wget-devel/Makefile
index 1d498de7477f..c188e70e41b3 100644
--- a/ftp/wget-devel/Makefile
+++ b/ftp/wget-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wget
PORTVERSION= 1.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp www ipv6
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.dl.ac.uk/ccp14/ftp-mirror/wget/pub/unix/util/wget/ \
diff --git a/ftp/wget-devel/files/patch-host.c b/ftp/wget-devel/files/patch-host.c
new file mode 100644
index 000000000000..9495ff9ec250
--- /dev/null
+++ b/ftp/wget-devel/files/patch-host.c
@@ -0,0 +1,11 @@
+--- src/host.c.orig Thu Aug 9 10:11:56 2001
++++ src/host.c Thu Aug 9 10:12:27 2001
+@@ -106,7 +106,7 @@
+
+ hp = gethostbyname2(name, af);
+ if (!hp) {
+- if (inet_pton(af, name, addr) != -1) {
++ if (inet_pton(af, name, addr) == 1) {
+ switch (af) {
+ case AF_INET:
+ socksize = sizeof (struct sockaddr_in);