aboutsummaryrefslogtreecommitdiff
path: root/ftp/wget
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2001-12-18 19:47:45 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2001-12-18 19:47:45 +0000
commitdfdba66be670cc1d049d59b2407ef3913722fd84 (patch)
tree7185f09f394a4b57cc0547167c493e8f6ca684ac /ftp/wget
parentb81be7049148cd66d3ad8661f64cf83fee1b94e6 (diff)
downloadports-dfdba66be670cc1d049d59b2407ef3913722fd84.tar.gz
ports-dfdba66be670cc1d049d59b2407ef3913722fd84.zip
Notes
Diffstat (limited to 'ftp/wget')
-rw-r--r--ftp/wget/Makefile4
-rw-r--r--ftp/wget/files/patch-configure.in32
-rw-r--r--ftp/wget/files/patch-src_recur.c17
3 files changed, 51 insertions, 2 deletions
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index caf5aad9f8cb..c532a9e08910 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wget
PORTVERSION= 1.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp www
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.dl.ac.uk/ccp14/ftp-mirror/wget/pub/unix/util/wget/ \
@@ -25,7 +25,7 @@ USE_OPENSSL= yes
CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE}
.endif
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_AUTOCONF= yes
CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
LIBS=-L${LOCALBASE}/lib
diff --git a/ftp/wget/files/patch-configure.in b/ftp/wget/files/patch-configure.in
new file mode 100644
index 000000000000..aab0684fbb72
--- /dev/null
+++ b/ftp/wget/files/patch-configure.in
@@ -0,0 +1,32 @@
+Index: configure.in
+===================================================================
+RCS file: /pack/anoncvs/wget/configure.in,v
+retrieving revision 1.30
+retrieving revision 1.31
+diff -u -r1.30 -r1.31
+--- configure.in 2001/12/06 10:45:26 1.30
++++ configure.in 2001/12/11 06:20:22 1.31
+@@ -340,18 +340,18 @@
+ dnl Find an md5 implementation.
+ dnl
+
+-dnl On Solaris, we use libmd5. If we're compiled with OpenSSL, use
+-dnl OpenSSL's md5 support. Otherwise, use our own md5.
+-
+ if test x$wget_need_md5 = xyes
+ then
+ MD5_OBJ='gen-md5$o'
+
+ found_md5=no
+
+- dnl First check for Solaris md5.
++ dnl Check for the system MD5 library on Solaris. We don't check for
++ dnl something simple like "MD5Update" because there are a number of
++ dnl MD5 implementations that use that name. md5_calc is, hopefully,
++ dnl specific to the Solaris MD5 library.
+ if test x$found_md5 = xno; then
+- AC_CHECK_LIB(md5, MD5Update, [
++ AC_CHECK_LIB(md5, md5_calc, [
+ AC_DEFINE(HAVE_SOLARIS_MD5)
+ LIBS="-lmd5 $LIBS"
+ found_md5=yes
diff --git a/ftp/wget/files/patch-src_recur.c b/ftp/wget/files/patch-src_recur.c
new file mode 100644
index 000000000000..a7cfd8800b0c
--- /dev/null
+++ b/ftp/wget/files/patch-src_recur.c
@@ -0,0 +1,17 @@
+Index: src/recur.c
+===================================================================
+RCS file: /pack/anoncvs/wget/src/recur.c,v
+retrieving revision 1.37
+retrieving revision 1.38
+diff -u -r1.37 -r1.38
+--- src/recur.c 2001/12/13 19:18:31 1.37
++++ src/recur.c 2001/12/18 15:22:03 1.38
+@@ -237,7 +237,7 @@
+ int oldrec = opt.recursive;
+
+ opt.recursive = 0;
+- status = retrieve_url (url, &file, &redirected, NULL, &dt);
++ status = retrieve_url (url, &file, &redirected, referer, &dt);
+ opt.recursive = oldrec;
+
+ if (file && status == RETROK