aboutsummaryrefslogtreecommitdiff
path: root/ftp/wmget/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-27 15:58:52 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-27 15:58:52 +0000
commit4ef07d396ea4911e4be5f529b38cf1676a6cb092 (patch)
treed9800f6da102f7aea310e5e5e4cd08b332e1c2f1 /ftp/wmget/Makefile
parentdcbed75aab93c51937a7220959d585705e12a89c (diff)
downloadports-4ef07d396ea4911e4be5f529b38cf1676a6cb092.tar.gz
ports-4ef07d396ea4911e4be5f529b38cf1676a6cb092.zip
Notes
Diffstat (limited to 'ftp/wmget/Makefile')
-rw-r--r--ftp/wmget/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/ftp/wmget/Makefile b/ftp/wmget/Makefile
new file mode 100644
index 000000000000..29a30a55251f
--- /dev/null
+++ b/ftp/wmget/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: wmget
+# Date created: 05.01.2004
+# Whom: Ulrich Spoerlein <q@uni.de>
+#
+# $FreeBSD$
+
+PORTNAME= wmget
+PORTVERSION= 0.5.0
+CATEGORIES= ftp
+MASTER_SITES= http://amtrickey.net/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= q@uni.de
+COMMENT= Dock app for Window Maker providing wget functionality
+
+LIB_DEPENDS= curl.2:${PORTSDIR}/ftp/curl
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GETOPT_LONG= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAKE_ENV+= ${CONFIGURE_ENV}
+
+MAN1= wmget.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/wmget ${PREFIX}/bin
+.if !defined(NO_INSTALL_MANPAGES)
+ ${INSTALL_MAN} ${WRKSRC}/wmget.1 ${PREFIX}/man/man1
+.endif
+
+.include <bsd.port.mk>