aboutsummaryrefslogtreecommitdiff
path: root/ftp/wu-ftpd
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2005-04-05 00:25:01 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2005-04-05 00:25:01 +0000
commit902ee3e5f2c9c3276215461a74e1666449769c0b (patch)
treeab350352bdb3f63ef8e4cbaed0593fc501114dc5 /ftp/wu-ftpd
parentc5ff3a0d743d3194bac63a6b44338db785824840 (diff)
downloadports-902ee3e5f2c9c3276215461a74e1666449769c0b.tar.gz
ports-902ee3e5f2c9c3276215461a74e1666449769c0b.zip
Notes
Diffstat (limited to 'ftp/wu-ftpd')
-rw-r--r--ftp/wu-ftpd/Makefile4
-rw-r--r--ftp/wu-ftpd/files/patch-aa27
2 files changed, 25 insertions, 6 deletions
diff --git a/ftp/wu-ftpd/Makefile b/ftp/wu-ftpd/Makefile
index d1b9a15e485e..f38e1ee80fbf 100644
--- a/ftp/wu-ftpd/Makefile
+++ b/ftp/wu-ftpd/Makefile
@@ -9,11 +9,11 @@
PORTNAME= wu-ftpd
PORTVERSION= 2.6.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.wu-ftpd.org/pub/wu-ftpd/
PATCH_SITES= ftp://ftp.wu-ftpd.org/pub/wu-ftpd/patches/apply_to_2.6.2/
-PATCHFILES= connect-dos.patch realpath.patch
+PATCHFILES= connect-dos.patch realpath.patch
MAINTAINER= ache@FreeBSD.org
COMMENT= A replacement ftp server for Un*x systems
diff --git a/ftp/wu-ftpd/files/patch-aa b/ftp/wu-ftpd/files/patch-aa
index fb9496f1c4fe..6ea6479bb5d5 100644
--- a/ftp/wu-ftpd/files/patch-aa
+++ b/ftp/wu-ftpd/files/patch-aa
@@ -1,5 +1,5 @@
---- src/ftpd.c.orig Mon Mar 8 07:24:50 2004
-+++ src/ftpd.c Mon Mar 8 07:24:50 2004
+--- src/ftpd.c.orig Tue Apr 5 03:22:01 2005
++++ src/ftpd.c Tue Apr 5 04:10:13 2005
@@ -447,7 +447,6 @@
#ifdef OPIE
#include <opie.h>
@@ -24,10 +24,10 @@
if (pwd == NULL || skeychallenge(&skey, pwd->pw_name, sbuf))
- sprintf(buf, "Password required for %s.", name);
-+ snprintf(buf, 128, "Password required for %s.", name);
++ snprintf(buf, sizeof(buf)-1, "Password required for %s.", name);
else
- sprintf(buf, "%s %s for %s.", sbuf,
-+ snprintf(buf, 128, "%s %s for %s.", sbuf,
++ snprintf(buf, sizeof(buf)-1, "%s %s for %s.", sbuf,
pwok ? "allowed" : "required", name);
return (buf);
}
@@ -95,3 +95,22 @@
#ifdef VERBOSE_ERROR_LOGING
syslog(LOG_NOTICE, "FTP LOGIN FAILED (cannot chdir) for %s, %s",
remoteident, pw->pw_name);
+@@ -7469,6 +7471,8 @@
+ in++;
+ if (*in == '/')
+ in++;
++ else
++ out++;
+ }
+ else if ((in[0] == '.') && (in[1] == '.') && ((in[2] == '/') || (in[2] == '\0'))) {
+ if (out == path) {
+@@ -7497,6 +7501,9 @@
+ }
+ else {
+ do
++ if ((in[0] == '*') && (in[1] == '*'))
++ in++;
++ else
+ *out++ = *in++;
+ while ((*in != '\0') && (*in != '/'));
+ if (*in == '/')