aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2018-10-08 08:52:51 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2018-10-08 08:52:51 +0000
commit3a5533b48d284380e9a3a97b953e1a555242caf2 (patch)
treeadfd6b20496941d7ab22cbbb81aacdf0db2ffbe3 /ftp
parentefe5dba5fb2dfc94a3bb101e8b9920b0ab69c2c3 (diff)
downloadports-3a5533b48d284380e9a3a97b953e1a555242caf2.tar.gz
ports-3a5533b48d284380e9a3a97b953e1a555242caf2.zip
Add PHP 7.3 RC2 to the ports-tree.
Notable changes: - Switch from PCRE to PCRE2 - Many modules now require PCRE2 for building - graphics/php73-gd: X11 option is no longer default Changes to Mk/Uses/php.mk approved by ale
Notes
Notes: svn path=/head/; revision=481525
Diffstat (limited to 'ftp')
-rw-r--r--ftp/php73-curl/Makefile11
-rw-r--r--ftp/php73-ftp/Makefile15
2 files changed, 26 insertions, 0 deletions
diff --git a/ftp/php73-curl/Makefile b/ftp/php73-curl/Makefile
new file mode 100644
index 000000000000..27b10dbc1482
--- /dev/null
+++ b/ftp/php73-curl/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= ftp
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -curl
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/ftp/php73-ftp/Makefile b/ftp/php73-ftp/Makefile
new file mode 100644
index 000000000000..6c08894fe3ad
--- /dev/null
+++ b/ftp/php73-ftp/Makefile
@@ -0,0 +1,15 @@
+# $FreeBSD$
+
+CATEGORIES= ftp
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -ftp
+
+TEST_TARGET= test
+
+post-patch:
+ @${REINPLACE_CMD} s/HAVE_OPENSSL_EXT/__FreeBSD__/ \
+ ${WRKSRC}/ftp.* ${WRKSRC}/php_ftp.*
+
+.include "${MASTERDIR}/Makefile"