aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2001-03-26 15:34:02 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2001-03-26 15:34:02 +0000
commit6ea704d137285277742ee69312034316a78041d6 (patch)
tree627cbdb44fc1ad099b814812c5f3e29f48402031 /ftp
parent77cdd47db04855f2e383ef5c846e0504996770b8 (diff)
downloadports-6ea704d137285277742ee69312034316a78041d6.tar.gz
ports-6ea704d137285277742ee69312034316a78041d6.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/kmago/Makefile32
-rw-r--r--ftp/kmago/distinfo1
-rw-r--r--ftp/kmago/pkg-comment1
-rw-r--r--ftp/kmago/pkg-descr13
-rw-r--r--ftp/kmago/pkg-plist9
6 files changed, 57 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 4e704d2a3157..8c1a04fc1035 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -20,6 +20,7 @@
SUBDIR += hsftp
SUBDIR += jmirror
SUBDIR += junglemonkey
+ SUBDIR += kmago
SUBDIR += lftp
SUBDIR += llnlxdir
SUBDIR += llnlxftp
diff --git a/ftp/kmago/Makefile b/ftp/kmago/Makefile
new file mode 100644
index 000000000000..124821e18445
--- /dev/null
+++ b/ftp/kmago/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: kmago
+# Date created: 26 March 2001
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kmago
+PORTVERSION= 1.1
+CATEGORIES= ftp kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= kmago
+
+MAINTAINER= demon@FreeBSD.org
+
+LIB_DEPENDS= kdecore.4:${PORTSDIR}/x11/kdelibs2
+
+USE_QT2= yes
+MOC?= ${X11BASE}/bin/moc2
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
+ --with-qt-libraries=${X11BASE}/lib \
+ --with-extra-libs=${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include" \
+ MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
+ LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
+
+post-patch:
+ @${PERL} -pi -e 's#lqt#lqt2#g' ${WRKSRC}/configure ${WRKSRC}/kmago/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/ftp/kmago/distinfo b/ftp/kmago/distinfo
new file mode 100644
index 000000000000..e8c3fb12d8ad
--- /dev/null
+++ b/ftp/kmago/distinfo
@@ -0,0 +1 @@
+MD5 (kmago-1.1.tar.gz) = 12eb90cbaf23520576af4693a8133a42
diff --git a/ftp/kmago/pkg-comment b/ftp/kmago/pkg-comment
new file mode 100644
index 000000000000..5bede7cc7b60
--- /dev/null
+++ b/ftp/kmago/pkg-comment
@@ -0,0 +1 @@
+KDE Multiple Automated Get Operations
diff --git a/ftp/kmago/pkg-descr b/ftp/kmago/pkg-descr
new file mode 100644
index 000000000000..3749d2fa35fa
--- /dev/null
+++ b/ftp/kmago/pkg-descr
@@ -0,0 +1,13 @@
+KMago (KDE Multiple Automated Get Operations) is a download manager which works
+as a frontend to GNU wget or with the KDE kioslaves. KMago features:
+
+Drag'n'drop operations with other applications (Konqueror, Netscape, etc.)
+ and between KMago widgets (including drop targets and a panel tray icon);
+Multiple prioritized downloads with a selectable priority policy;
+Transfers grouping;
+Multiple downloads control with priority and selectable priority policy;
+A download resume capability;
+Cookie and HTTP-related management offered by KDE I/O library; and
+The stability and reliability of the venerable GNU wget.
+
+WWW: http://kmago.sourceforge.net/
diff --git a/ftp/kmago/pkg-plist b/ftp/kmago/pkg-plist
new file mode 100644
index 000000000000..c94bbaea80e1
--- /dev/null
+++ b/ftp/kmago/pkg-plist
@@ -0,0 +1,9 @@
+bin/kmago
+share/apps/kmago/kmagoui.rc
+share/icons/locolor/16x16/apps/kmago.xpm
+share/icons/locolor/32x32/apps/kmago.xpm
+share/icons/hicolor/22x22/apps/kmago.png
+share/icons/hicolor/32x32/apps/kmago.png
+share/icons/hicolor/48x48/apps/kmago.png
+share/applnk/Internet/kmago.desktop
+@dirrm share/apps/kmago