aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-08-16 12:25:28 +0000
committerSteve Wills <swills@FreeBSD.org>2018-08-16 12:25:28 +0000
commitd19bfbb151d28added828997317c14c25bcfd00a (patch)
tree9f4b89bb0fcdc09b3b2f0c8e6cd5c6ddd4dcaf70 /ftp
parent467834e59c0dfb9bba698e7b0324bec23f73426b (diff)
downloadports-d19bfbb151d28added828997317c14c25bcfd00a.tar.gz
ports-d19bfbb151d28added828997317c14c25bcfd00a.zip
ftp/ocaml-ocurl: Update to 0.8.2
While here, assign maintainer to submitter PR: 230446 Submitted by: Nathan <ndowens@yahoo.com>
Notes
Notes: svn path=/head/; revision=477326
Diffstat (limited to 'ftp')
-rw-r--r--ftp/ocaml-ocurl/Makefile39
-rw-r--r--ftp/ocaml-ocurl/distinfo6
-rw-r--r--ftp/ocaml-ocurl/pkg-plist2
3 files changed, 27 insertions, 20 deletions
diff --git a/ftp/ocaml-ocurl/Makefile b/ftp/ocaml-ocurl/Makefile
index 5e14dffcdb2a..4bc43b6aa478 100644
--- a/ftp/ocaml-ocurl/Makefile
+++ b/ftp/ocaml-ocurl/Makefile
@@ -2,14 +2,16 @@
# $FreeBSD$
PORTNAME= ocurl
-PORTVERSION= 0.7.9
+PORTVERSION= 0.8.2
CATEGORIES= ftp
-MASTER_SITES= http://ygrek.org.ua/p/release/ocurl/
PKGNAMEPREFIX= ocaml-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ndowens@yahoo.com
COMMENT= Interface for OCaml to the curl lib
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= ocamlc:lang/ocaml \
ocamlfind:devel/ocaml-findlib
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -17,8 +19,10 @@ LIB_DEPENDS= libcurl.so:ftp/curl
USES= gmake
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+="--with-findlib"
-MAKE_JOBS_UNSAFE= yes
+#CONFIGURE_ARGS+="--with-findlib"
+
+USE_GITHUB= yes
+GH_ACCOUNT= ygrek
USE_OCAML= yes
USE_OCAML_CAMLP4= yes
@@ -26,23 +30,24 @@ USE_OCAML_FINDLIB= yes
USE_OCAML_LDCONFIG= yes
OCAML_PKGDIRS= curl
-OPTIONS_DEFINE= LWT
-OPTIONS_DEFAULT=LWT
-OPTIONS_SUB= yes
-LWT_DESC= Include threading support (ocaml-lwt)
-LWT_RUN_DEPENDS=${LOCALBASE}/${OCAML_SITELIBDIR}/lwt/lwt.a:devel/ocaml-lwt
-LWT_BUILD_DEPENDS=${LWT_RUN_DEPENDS}
+OPTIONS_DEFINE= LWT
+OPTIONS_DEFAULT= LWT
+OPTIONS_SUB= yes
+LWT_DESC= Include threading support (ocaml-lwt)
+LWT_RUN_DEPENDS= ${LOCALBASE}/${OCAML_SITELIBDIR}/lwt/lwt.a:devel/ocaml-lwt
+LWT_BUILD_DEPENDS= ${LWT_RUN_DEPENDS}
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${OCAML_SITELIBDIR}/curl/dllcurl-helper.so
+post-install-LWT-on:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${OCAML_SITELIBDIR}/curl/curl_lwt.cmxs
-.include <bsd.port.options.mk>
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${OCAML_SITELIBDIR}/curl/dllcurl-helper.so \
+ ${STAGEDIR}${PREFIX}/${OCAML_SITELIBDIR}/curl/curl.cmxs \
-.if ! ${PORT_OPTIONS:MLWT}
+post-configure-LWT-off:
# Override auto-detection
-post-configure:
+
${REINPLACE_CMD} 's/(lwt,no)/(no,no)/' ${WRKSRC}/Makefile \
${WRKSRC}/examples/Makefile
-.endif
.include <bsd.port.mk>
diff --git a/ftp/ocaml-ocurl/distinfo b/ftp/ocaml-ocurl/distinfo
index e46d4a46cc07..4d7f7181386e 100644
--- a/ftp/ocaml-ocurl/distinfo
+++ b/ftp/ocaml-ocurl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1476625190
-SHA256 (ocurl-0.7.9.tar.gz) = 36a0103cf062ea2c5685a1615295cf765e49495adfcc620e4c17443e46b5a65e
-SIZE (ocurl-0.7.9.tar.gz) = 108242
+TIMESTAMP = 1533686147
+SHA256 (ygrek-ocurl-0.8.2_GH0.tar.gz) = dcbadbdf97830de04a68454571bec9592c7f7be135bf1a1a5d8f8aa35c28ed24
+SIZE (ygrek-ocurl-0.8.2_GH0.tar.gz) = 111713
diff --git a/ftp/ocaml-ocurl/pkg-plist b/ftp/ocaml-ocurl/pkg-plist
index cba42780e0eb..5b9ea9676479 100644
--- a/ftp/ocaml-ocurl/pkg-plist
+++ b/ftp/ocaml-ocurl/pkg-plist
@@ -6,6 +6,8 @@
%%OCAML_SITELIBDIR%%/curl/curl.cmti
%%OCAML_SITELIBDIR%%/curl/curl.cmx
%%OCAML_SITELIBDIR%%/curl/curl.cmxa
+%%OCAML_SITELIBDIR%%/curl/curl.cmxs
+%%LWT%%%%OCAML_SITELIBDIR%%/curl/curl_lwt.cmxs
%%OCAML_SITELIBDIR%%/curl/curl.mli
%%LWT%%%%OCAML_SITELIBDIR%%/curl/curl_lwt.cmi
%%LWT%%%%OCAML_SITELIBDIR%%/curl/curl_lwt.cmo