aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-11-23 14:06:53 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-11-23 14:06:53 +0000
commit2668d3d08d200bc7a36273116e9c986fb7a30ca3 (patch)
treed1fa4bdbf7fb78cd0997877dedb65e597f47063a /ftp
parent632dfdfde4827198c2215d525a91f7814cead9be (diff)
downloadports-2668d3d08d200bc7a36273116e9c986fb7a30ca3.tar.gz
ports-2668d3d08d200bc7a36273116e9c986fb7a30ca3.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/prozilla/Makefile22
-rw-r--r--ftp/prozilla/distinfo5
-rw-r--r--ftp/prozilla/files/patch-connect.c126
-rw-r--r--ftp/prozilla/files/patch-connection.c15
-rw-r--r--ftp/prozilla/files/patch-ftp-retr.c10
-rw-r--r--ftp/prozilla/files/patch-ftpsearch.c10
-rw-r--r--ftp/prozilla/files/patch-http-retr.c10
-rw-r--r--ftp/prozilla/files/patch-ltmain.sh16
-rw-r--r--ftp/prozilla/files/patch-misc.c10
-rw-r--r--ftp/prozilla/files/patch-ping.c10
-rw-r--r--ftp/prozilla/pkg-plist16
11 files changed, 41 insertions, 209 deletions
diff --git a/ftp/prozilla/Makefile b/ftp/prozilla/Makefile
index 50c8e51766a1..ff5393b8f814 100644
--- a/ftp/prozilla/Makefile
+++ b/ftp/prozilla/Makefile
@@ -6,32 +6,26 @@
#
PORTNAME= prozilla
-PORTVERSION= 1.3.7.4
+PORTVERSION= 2.0.1
CATEGORIES= ftp
MASTER_SITES= http://prozilla.genesys.ro/downloads/prozilla/tarballs/
MAINTAINER= alejandro@varnet.biz
COMMENT= ProZilla is a fast download accelerator
+USE_BZIP2= yes
USE_GETOPT_LONG=yes
USE_GMAKE= yes
+USE_LIBTOOL_VER=15
USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-MAN1= proz.1 prozilla.1
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
-.if !defined(NOPORTDOCS)
-PORTDOCS= ANNOUNCE AUTHORS COPYING CREDITS ChangeLog INSTALL FAQ NEWS \
- README TODO
-.endif
+MAN1= proz.1
post-patch:
- @${REINPLACE_CMD} -e 's|%Ld|%lld|g' ${WRKSRC}/src/*.c ${WRKSRC}/src/*.h
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
-.endif
+ ${REINPLACE_CMD} -e 's|CPPFLAGS =|CPPFLAGS = @CPPFLAGS@|' \
+ ${WRKSRC}/libprozilla/src/Makefile.in
.include <bsd.port.mk>
diff --git a/ftp/prozilla/distinfo b/ftp/prozilla/distinfo
index c3ee1e893a7c..4ee4de0b429a 100644
--- a/ftp/prozilla/distinfo
+++ b/ftp/prozilla/distinfo
@@ -1,2 +1,3 @@
-MD5 (prozilla-1.3.7.4.tar.gz) = b594b55b1b49a8eca2505173cc1bfc44
-SIZE (prozilla-1.3.7.4.tar.gz) = 222229
+MD5 (prozilla-2.0.1.tar.bz2) = cb9ae30db4445fcb55b93b68cf2b6d4e
+SHA256 (prozilla-2.0.1.tar.bz2) = 941c54260d21627d24db0a8a9d112a701ef66725c22656c6ce8ffd9943911c55
+SIZE (prozilla-2.0.1.tar.bz2) = 873347
diff --git a/ftp/prozilla/files/patch-connect.c b/ftp/prozilla/files/patch-connect.c
deleted file mode 100644
index 77a9325fa148..000000000000
--- a/ftp/prozilla/files/patch-connect.c
+++ /dev/null
@@ -1,126 +0,0 @@
---- src/connect.c.orig Sat Feb 26 16:47:17 2005
-+++ src/connect.c Sun Oct 9 13:06:34 2005
-@@ -24,9 +24,11 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <unistd.h>
-+#include <sys/types.h>
- #include <sys/socket.h>
- #include <fcntl.h>
- #include <netdb.h>
-+#include <netinet/in_systm.h>
- #include <netinet/in.h>
- #include <netinet/ip.h>
- #include <netdb.h>
-@@ -42,53 +44,52 @@
- #include "runtime.h"
- #include "debug.h"
-
-+static pthread_mutex_t __thread_safe_lock = PTHREAD_MUTEX_INITIALIZER;
-+
- uerr_t connect_to_server(int *sock, char *name, int port, int timeout)
- {
-- unsigned int portnum;
-+ char szPort[10];
- int status;
-- struct sockaddr_in server;
-- struct hostent *hp, hostbuf;
- extern int h_errno;
- /* int opt; */
- int noblock, flags;
-
-- char *tmphstbuf;
-- size_t hstbuflen = 2048;
-- tmphstbuf = kmalloc(hstbuflen);
-+ struct addrinfo hints, *res=NULL;
-+ struct addrinfo *res0=NULL;
-+ int error;
-
- assert(name != NULL);
-
-- portnum = port;
-- memset((void *) &server, 0, sizeof(server));
-+ memset(&hints, 0, sizeof(hints));
-+ memset(szPort, 0, sizeof(szPort));
-+ snprintf(szPort, sizeof(szPort), "%d", port);
-+ hints.ai_family = AF_INET;
-+ hints.ai_socktype = SOCK_STREAM;
-
- message("Resolving %s", name);
-
-- hp=k_gethostname (name,&hostbuf,&tmphstbuf,&hstbuflen);
--
-- if (hp == NULL)
-- {
-- message("Failed to resolve %s", name);
-- return HOSTERR;
-- }
-+ error = getaddrinfo(name, szPort, &hints, &res);
-+ if (error) {
-+ message("Failed to resolve %s", name);
-+ pthread_mutex_unlock(&__thread_safe_lock);
-+ freeaddrinfo(res);
-+ return HOSTERR;
-+ }
-
- message("Resolved %s !", name);
--
-- memcpy((void *) &server.sin_addr, hp->h_addr, hp->h_length);
-- server.sin_family = hp->h_addrtype;
-- server.sin_port = htons(portnum);
-
-- if (tmphstbuf)
-- {
-- free(tmphstbuf);
-- tmphstbuf = NULL;
-- }
-+ res0 = (struct addrinfo *) malloc(sizeof(struct addrinfo));
-+ memcpy(res0, res, sizeof(struct addrinfo));
-+ freeaddrinfo(res);
-+ pthread_mutex_unlock(&__thread_safe_lock);
-
- /*
- * create socket
- */
-- if ((*sock = socket(AF_INET, SOCK_STREAM, 0)) < 1)
-+ if ((*sock = socket(res0->ai_family, res0->ai_socktype, 0)) < 1)
- {
- message("unable to create socket\n");
-+ free(res0);
- return CONSOCKERR;
- }
- /*Experimental */
-@@ -100,8 +101,7 @@
-
- message("Connecting to server.......");
-
--
-- status = connect(*sock, (struct sockaddr *) &server, sizeof(server));
-+ status = connect(*sock, res0->ai_addr, res0->ai_addrlen);
-
- if (status == -1 && noblock != -1 && errno == EINPROGRESS)
- {
-@@ -137,10 +137,13 @@
- {
- close(*sock);
-
-- if (errno == ECONNREFUSED)
-+ if (errno == ECONNREFUSED) {
-+ free(res0);
- return CONREFUSED;
-- else
-+ } else {
-+ free(res0);
- return CONERROR;
-+ }
- } else
- {
- flags = fcntl(*sock, F_GETFL, 0);
-@@ -156,6 +159,7 @@
- * (char *) &opt, (int) sizeof(opt));
- */
- message("Connect OK!");
-+ free(res0);
- return NOCONERROR;
- }
-
diff --git a/ftp/prozilla/files/patch-connection.c b/ftp/prozilla/files/patch-connection.c
deleted file mode 100644
index 9edd9e1053fe..000000000000
--- a/ftp/prozilla/files/patch-connection.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/connection.c.ori Sat Jan 25 00:33:14 2003
-+++ src/connection.c Sat Jan 25 00:33:38 2003
-@@ -30,7 +30,12 @@
- #include <assert.h>
- #include <pthread.h>
-
-+#ifdef __FreeBSD__
-+#include <sys/param.h>
-+#include <sys/mount.h>
-+#else
- #include <sys/vfs.h>
-+#endif
-
- #include "connection.h"
- #include "misc.h"
diff --git a/ftp/prozilla/files/patch-ftp-retr.c b/ftp/prozilla/files/patch-ftp-retr.c
deleted file mode 100644
index 516fefbf4e47..000000000000
--- a/ftp/prozilla/files/patch-ftp-retr.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/ftp-retr.c.ori Sat Jan 25 00:40:45 2003
-+++ src/ftp-retr.c Sat Jan 25 00:40:56 2003
-@@ -32,6 +32,7 @@
- #include <netdb.h>
- #include <sys/socket.h>
- #include <sys/time.h>
-+#include <netinet/in_systm.h>
- #include <netinet/in.h>
- #include <netinet/ip.h>
- #include <netinet/tcp.h>
diff --git a/ftp/prozilla/files/patch-ftpsearch.c b/ftp/prozilla/files/patch-ftpsearch.c
deleted file mode 100644
index c5ecb09902dc..000000000000
--- a/ftp/prozilla/files/patch-ftpsearch.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/ftpsearch.c.ori Sat Jan 25 00:45:38 2003
-+++ src/ftpsearch.c Sat Jan 25 00:45:48 2003
-@@ -25,6 +25,7 @@
- #include <sys/socket.h>
- #include <fcntl.h>
- #include <netdb.h>
-+#include <netinet/in_systm.h>
- #include <netinet/in.h>
- #include <netinet/ip.h>
- #include <arpa/inet.h>
diff --git a/ftp/prozilla/files/patch-http-retr.c b/ftp/prozilla/files/patch-http-retr.c
deleted file mode 100644
index ff51af07226f..000000000000
--- a/ftp/prozilla/files/patch-http-retr.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/http-retr.c.ori Sat Jan 25 00:49:21 2003
-+++ src/http-retr.c Sat Jan 25 00:49:34 2003
-@@ -32,6 +32,7 @@
- #include <fcntl.h>
- #include <sys/socket.h>
- #include <sys/time.h>
-+#include <netinet/in_systm.h>
- #include <netinet/in.h>
- #include <netinet/ip.h>
- #include <netinet/tcp.h>
diff --git a/ftp/prozilla/files/patch-ltmain.sh b/ftp/prozilla/files/patch-ltmain.sh
new file mode 100644
index 000000000000..7f883792c4f8
--- /dev/null
+++ b/ftp/prozilla/files/patch-ltmain.sh
@@ -0,0 +1,16 @@
+--- ltmain.sh.orig Wed Nov 2 13:02:43 2005
++++ ltmain.sh Thu Nov 10 16:33:44 2005
+@@ -5771,11 +5771,13 @@
+ IFS="$save_ifs"
+ fi
+
++ if /usr/bin/false; then
+ # Install the pseudo-library for information purposes.
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/ftp/prozilla/files/patch-misc.c b/ftp/prozilla/files/patch-misc.c
deleted file mode 100644
index 20298f17aa85..000000000000
--- a/ftp/prozilla/files/patch-misc.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/misc.c.ori Sat Jan 25 01:38:04 2003
-+++ src/misc.c Sat Jan 25 01:38:40 2003
-@@ -24,7 +24,6 @@
- #include <stdio.h>
- #include <stdarg.h>
- #include <stdlib.h>
--#include <malloc.h>
- #include <string.h>
- #include <ctype.h>
- #include <curses.h>
diff --git a/ftp/prozilla/files/patch-ping.c b/ftp/prozilla/files/patch-ping.c
deleted file mode 100644
index d095e3988695..000000000000
--- a/ftp/prozilla/files/patch-ping.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/ping.c.ori Sat Jan 25 00:53:13 2003
-+++ src/ping.c Sat Jan 25 00:53:28 2003
-@@ -23,6 +23,7 @@
- #include <sys/socket.h>
- #include <fcntl.h>
- #include <netdb.h>
-+#include <netinet/in_systm.h>
- #include <netinet/in.h>
- #include <netinet/ip.h>
- #include <arpa/inet.h>
diff --git a/ftp/prozilla/pkg-plist b/ftp/prozilla/pkg-plist
index 397769ae78ef..893b3e27e31a 100644
--- a/ftp/prozilla/pkg-plist
+++ b/ftp/prozilla/pkg-plist
@@ -1,3 +1,15 @@
bin/proz
-@unexec if cmp -s %D/etc/prozilla.conf %D/etc/prozilla.conf-sample; then rm -f %D/etc/prozilla.conf; fi
-etc/prozilla.conf-sample
+include/common.h
+include/netrc.h
+include/prozilla.h
+lib/libprozilla.a
+lib/libprozilla.la
+share/locale/fr/LC_MESSAGES/proz.mo
+share/locale/it/LC_MESSAGES/.mo
+share/locale/it/LC_MESSAGES/proz.mo
+share/locale/nl/LC_MESSAGES/.mo
+share/locale/nl/LC_MESSAGES/proz.mo
+share/locale/pt_BR/LC_MESSAGES/.mo
+share/locale/pt_BR/LC_MESSAGES/proz.mo
+share/locale/ro/LC_MESSAGES/.mo
+share/locale/ro/LC_MESSAGES/proz.mo