aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
commit05317facbedf1ed4566b56f4e09e6e4a49fc3f38 (patch)
treef0614b64c20d137667eadfbdc5663150937dc6c3 /ftp
parentf287925fdbb7ff7ab55ee8aaa28cf756fe49a296 (diff)
Update CentOS base to 6.5, add userland ports
The Fedora 10 infrastructure ports have been in use since June 2009 and, while having served a great deed, have become unsupported upstream and hence affected by unfixed security vulnerabilities. In addition to that, many recent Linux binaries need newer libc / stdlibc++ versions. This commit adds the linux-c6- userland as drop-in replacement for the -f10 infrastructure, as well as upgrading the linux_base-c6 port to CentOS 6.5. If you want to switch to linux-c6 ports, please define at /etc/make.conf: OVERRIDE_LINUX_BASE_PORT=c6 OVERRIDE_LINUX_NONBASE_PORTS=c6 Additionally, please add the following line to /etc/sysctl.conf: compat.linux.osrelease=2.6.18 Upgrading procedures are shown in /usr/ports/UPDATING. This work has been inspired by Artyom Mirgorodskiy's post to emulation@ in November 2013, using and extending mav@'s work. It has been tested extensively and most reported issues were already fixed. Please report any additional bug or "features" to the emulation mailing list. Many thanks to: mav@, rene@, allanjude@, netchild@, antoine@, everyone who's filed Issues and Pull requests on GitHub, PR: 186820 Differential Revision: https://reviews.freebsd.org/D793 Reviewed by: allanjude, antoine, bapt, rene Approved by: portmgr (antoine, bapt) Approved by: koobs (mentor) Sponsored by: Perceivon Hosting Inc.
Notes
Notes: svn path=/head/; revision=368845
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/linux-c6-curl/Makefile30
-rw-r--r--ftp/linux-c6-curl/distinfo.i6866
-rw-r--r--ftp/linux-c6-curl/pkg-descr3
-rw-r--r--ftp/linux-f10-curl/Makefile14
5 files changed, 47 insertions, 7 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 58f0b28dcfca..a75bc7d5eb68 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -39,6 +39,7 @@
SUBDIR += jftp
SUBDIR += jftpgw
SUBDIR += lftp
+ SUBDIR += linux-c6-curl
SUBDIR += linux-f10-curl
SUBDIR += llnlxdir
SUBDIR += llnlxftp
diff --git a/ftp/linux-c6-curl/Makefile b/ftp/linux-c6-curl/Makefile
new file mode 100644
index 000000000000..a01cf18124a5
--- /dev/null
+++ b/ftp/linux-c6-curl/Makefile
@@ -0,0 +1,30 @@
+# Created by: Artyom Mirgorodskiy <artyom.mirgorodsky@gmail.com>
+# $FreeBSD$
+
+PORTNAME= curl
+PORTVERSION= 7.19.7
+CATEGORIES= ftp linux
+DISTFILES= curl-${PORTVERSION}-${RPMVERSION}.${LINUX_RPM_ARCH}.rpm \
+ libcurl-${PORTVERSION}-${RPMVERSION}.${LINUX_RPM_ARCH}.rpm
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Command line tool for transferring files with URL syntax (Linux CentOS ${LINUX_DIST_VER})
+
+CONFLICTS= linux-curl-[0-9]* linux-f10-curl-[0-9]*
+
+ONLY_FOR_ARCHS= i386 amd64
+
+USE_LINUX= c6
+USE_LINUX_APPS= openldap libssh2 # cyrus-sasl2
+USE_LINUX_RPM= yes
+RPMVERSION= 37.el6_4
+BRANDELF_FILES= usr/bin/curl
+USE_LDCONFIG= yes
+
+PLIST_FILES= usr/bin/curl usr/lib/libcurl.so.4 usr/lib/libcurl.so.4.1.1 \
+ usr/share/man/man1/curl.1.gz
+DOCSDIR= usr/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= BUGS COPYING FEATURES README TODO CHANGES FAQ MANUAL RESOURCES TheArtOfHttpScripting
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/ftp/linux-c6-curl/distinfo.i686 b/ftp/linux-c6-curl/distinfo.i686
new file mode 100644
index 000000000000..072c72b8885e
--- /dev/null
+++ b/ftp/linux-c6-curl/distinfo.i686
@@ -0,0 +1,6 @@
+SHA256 (rpm/i686/centos/6.5/curl-7.19.7-37.el6_4.i686.rpm) = 5393c38b98d9066a1d9c1f2ee54f643914d4da0b70f4516e90ec05fd6cb5009f
+SIZE (rpm/i686/centos/6.5/curl-7.19.7-37.el6_4.i686.rpm) = 197968
+SHA256 (rpm/i686/centos/6.5/libcurl-7.19.7-37.el6_4.i686.rpm) = 9d5a2fa689e12a0ff94d7c0e33effbcd2c7a5c04cd667e14e5015de786ad1b9f
+SIZE (rpm/i686/centos/6.5/libcurl-7.19.7-37.el6_4.i686.rpm) = 175232
+SHA256 (rpm/i686/centos/6.5/curl-7.19.7-37.el6_4.src.rpm) = ecc688b0bc8cfc4f51ae9d164c3c72f20faa6a440f4a80e83dd268508f2ba7ba
+SIZE (rpm/i686/centos/6.5/curl-7.19.7-37.el6_4.src.rpm) = 2099404
diff --git a/ftp/linux-c6-curl/pkg-descr b/ftp/linux-c6-curl/pkg-descr
new file mode 100644
index 000000000000..b3fbd37d1024
--- /dev/null
+++ b/ftp/linux-c6-curl/pkg-descr
@@ -0,0 +1,3 @@
+iasdf
+
+WWW: github.com/xmj/skype-ports
diff --git a/ftp/linux-f10-curl/Makefile b/ftp/linux-f10-curl/Makefile
index 3893c1e8ef9c..1673589f7be1 100644
--- a/ftp/linux-f10-curl/Makefile
+++ b/ftp/linux-f10-curl/Makefile
@@ -6,23 +6,18 @@ PORTVERSION= 7.19.6
PORTREVISION= 1
CATEGORIES= ftp linux
MASTER_SITES= CRITICAL/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
-PKGNAMEPREFIX= linux-f10-
DISTFILES= curl-${PORTVERSION}-${RPMVERSION}.i386.rpm \
libcurl-${PORTVERSION}-${RPMVERSION}.i386.rpm
-.if defined(PACKAGE_BUILDING)
-SRC_DISTFILES= curl-${PORTVERSION}-${RPMVERSION}.src.rpm
-ALWAYS_KEEP_DISTFILES= YES
-.endif
-
MAINTAINER= emulation@FreeBSD.org
COMMENT= Command line tool for transferring files with URL syntax (Linux Fedora 10)
CONFLICTS= linux-curl-[0-9]* linux-f8-curl-[0-9]*
+USE_LINUX= f10
USE_LINUX_RPM= yes
USE_LINUX_APPS= cyrus-sasl2 openldap
-LINUX_DIST_VER= 10
+
RPMVERSION= 2.fc10
USE_LDCONFIG= yes
BRANDELF_FILES= usr/bin/curl
@@ -33,4 +28,9 @@ PLIST_FILES= usr/bin/curl usr/lib/libcurl.so.4 usr/lib/libcurl.so.4.1.1 \
DOCSDIR= usr/share/doc/${PORTNAME}-${PORTVERSION}
PORTDOCS= BUGS COPYING FEATURES README TODO CHANGES FAQ MANUAL RESOURCES TheArtOfHttpScripting
+.if defined(PACKAGE_BUILDING)
+SRC_DISTFILES= curl-${PORTVERSION}-${RPMVERSION}.src.rpm
+ALWAYS_KEEP_DISTFILES= YES
+.endif
+
.include <bsd.port.mk>