aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2001-04-02 13:36:29 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2001-04-02 13:36:29 +0000
commita03266e0cd2544b367eb1717adff87b50e87842b (patch)
treec16cdfdc5c994da25777558a9370a9df1c860a15 /ftp
parent2b8431b4fdad8fc3a5ad9d43908ea01fa8279e8a (diff)
downloadports-a03266e0cd2544b367eb1717adff87b50e87842b.tar.gz
ports-a03266e0cd2544b367eb1717adff87b50e87842b.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/lukemftp/Makefile23
-rw-r--r--ftp/lukemftp/distinfo1
-rw-r--r--ftp/lukemftp/pkg-comment1
-rw-r--r--ftp/lukemftp/pkg-descr19
-rw-r--r--ftp/lukemftp/pkg-plist1
6 files changed, 46 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index e592b567e789..fc3b2ba48e0a 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -24,6 +24,7 @@
SUBDIR += lftp
SUBDIR += llnlxdir
SUBDIR += llnlxftp
+ SUBDIR += lukemftp
SUBDIR += mirror
SUBDIR += moxftp
SUBDIR += ncftp
diff --git a/ftp/lukemftp/Makefile b/ftp/lukemftp/Makefile
new file mode 100644
index 000000000000..9444302c07c1
--- /dev/null
+++ b/ftp/lukemftp/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: lukemftp
+# Date created: 04 Aug 2000
+# Whom: Chris D. Faulhaber <jedgar@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lukemftp
+PORTVERSION= 1.5
+CATEGORIES= ftp
+MASTER_SITES= ftp://ftp.netbsd.org/pub/NetBSD/misc/lukemftp/
+
+MAINTAINER= jedgar@FreeBSD.org
+
+GNU_CONFIGURE= yes
+
+MAN1= lukemftp.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/ftp ${PREFIX}/bin/lukemftp
+ ${INSTALL_MAN} ${WRKSRC}/src/ftp.1 ${PREFIX}/man/man1/lukemftp.1
+
+.include <bsd.port.mk>
diff --git a/ftp/lukemftp/distinfo b/ftp/lukemftp/distinfo
new file mode 100644
index 000000000000..959bbd4b5fce
--- /dev/null
+++ b/ftp/lukemftp/distinfo
@@ -0,0 +1 @@
+MD5 (lukemftp-1.5.tar.gz) = 0cd0fc2e3fca21ca56647b2e1142a01a
diff --git a/ftp/lukemftp/pkg-comment b/ftp/lukemftp/pkg-comment
new file mode 100644
index 000000000000..7d8ecff9c7bb
--- /dev/null
+++ b/ftp/lukemftp/pkg-comment
@@ -0,0 +1 @@
+Enhanced ftp client from NetBSD
diff --git a/ftp/lukemftp/pkg-descr b/ftp/lukemftp/pkg-descr
new file mode 100644
index 000000000000..0fdf650b36cb
--- /dev/null
+++ b/ftp/lukemftp/pkg-descr
@@ -0,0 +1,19 @@
+`lukemftp' is what many users affectionately call the enhanced ftp
+client in NetBSD.
+
+The enhancements over the standard ftp client in 4.4BSD include:
+ * command-line editing within ftp
+ * command-line fetching of URLS, including support for:
+ - http proxies (c.f: $http_proxy, $ftp_proxy)
+ - authentication
+ * context sensitive command and filename completion
+ * dynamic progress bar
+ * IPv6 support (from the WIDE project)
+ * modification time preservation
+ * paging of local and remote files, and of directory listings
+ (c.f: `lpage', `page', `pdir')
+ * passive mode support, with fallback to active mode
+ * `set option' override of ftp environment variables
+ * socks4/socks5 support
+ * TIS Firewall Toolkit gate ftp proxy support (c.f: `gate')
+ * transfer-rate throttling (c.f: `-T', `rate')
diff --git a/ftp/lukemftp/pkg-plist b/ftp/lukemftp/pkg-plist
new file mode 100644
index 000000000000..705387c21048
--- /dev/null
+++ b/ftp/lukemftp/pkg-plist
@@ -0,0 +1 @@
+bin/lukemftp