aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-03 18:09:23 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-03 18:09:23 +0000
commit90ceda6dbf9adb6cc2d6ad3e19c8604a3eb0d09f (patch)
treebebe55e16ba76208927dd87d2beb187237f7af27 /ftp
parent753ff075a1d80cafa931ad2a76b0b55a0e1c06d3 (diff)
downloadports-90ceda6dbf9adb6cc2d6ad3e19c8604a3eb0d09f.tar.gz
ports-90ceda6dbf9adb6cc2d6ad3e19c8604a3eb0d09f.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/phpwebftp/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/ftp/phpwebftp/Makefile b/ftp/phpwebftp/Makefile
index a53e5413dff4..9f78c16afbc9 100644
--- a/ftp/phpwebftp/Makefile
+++ b/ftp/phpwebftp/Makefile
@@ -20,14 +20,13 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
INSTALL_DIRE= ${INSTALL} -d -m 0755 -o ${WWWOWN} -g ${WWWGRP}
INSTALL_FILE= ${INSTALL} -m 0644 -o ${WWWOWN} -g ${WWWGRP}
-NO_STAGE= yes
post-extract:
@${FIND} -d ${WRKSRC} -name CVS -type d -exec ${RM} -R "{}" \;
do-install:
${INSTALL_DIRE} ${PREFIX}/${PHPWEBFTPDIR}
- @cd ${WRKSRC} && \
- ${FIND} * -type d -exec ${INSTALL_DIRE} "${PREFIX}/${PHPWEBFTPDIR}/{}" \; && \
+ (cd ${WRKSRC} && \
+ ${FIND} * -type d -exec ${INSTALL_DIRE} "${STAGEDIR}${PREFIX}/${PHPWEBFTPDIR}/{}" \; && \
${FIND} -E * -type f -iregex ".*\.(php|html|css|gif|js)" \
- -exec ${INSTALL_FILE} "{}" "${PREFIX}/${PHPWEBFTPDIR}/{}" \;
+ -exec ${INSTALL_FILE} "{}" "${STAGEDIR}${PREFIX}/${PHPWEBFTPDIR}/{}" \;)
.include <bsd.port.mk>