aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-07-25 17:45:09 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-07-25 17:45:09 +0000
commit8e2084427b6beb3d7a5458f5c7fcea080ddbb9b2 (patch)
tree17b7739cec5c8bd24318f8970c77d5508f40b335 /ftp
parent72f2f983e22b1d65c479ff810e3f1d974b5932ad (diff)
downloadports-8e2084427b6beb3d7a5458f5c7fcea080ddbb9b2.tar.gz
ports-8e2084427b6beb3d7a5458f5c7fcea080ddbb9b2.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/ftplocate/Makefile23
-rw-r--r--ftp/ftpmirror/Makefile8
2 files changed, 11 insertions, 20 deletions
diff --git a/ftp/ftplocate/Makefile b/ftp/ftplocate/Makefile
index 8c719ee7a02f..e2f1c423c875 100644
--- a/ftp/ftplocate/Makefile
+++ b/ftp/ftplocate/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Ftplocate
-# Date created: 7 December 1999
-# Whom: tung@turtle.ee.ncku.edu.tw
-#
+# Created by: tung@turtle.ee.ncku.edu.tw
# $FreeBSD$
-#
PORTNAME= ftplocate
PORTVERSION= 2.02
@@ -19,19 +15,14 @@ RUN_DEPENDS= glimpse:${PORTSDIR}/textproc/glimpse \
USE_PERL5= yes
NO_BUILD= yes
-PL_FILES= install.pl bin/dcollect.pl bin/dindex.pl bin/dsearch.pl \
- bin/flcollect.pl bin/flfilter.pl bin/flhistory.pl \
- bin/flindex.pl bin/flmap.pl bin/flsearch.pl \
- bin/flserv.pl bin/flsummary.pl bin/fltop.pl \
- bin/fltrain.pl bin/flcatsite.pl template/ftplocate
+USES= shebangfix
+SHEBANG_FILES= bin/*.pl template/ftplocate
post-extract:
-.for f in ${PL_FILES}
- @${PERL} -pi -e 's,/usr/bin/perl,${PERL},' ${WRKSRC}/${f}
-.endfor
- @${PERL} -pi -e 's,(/usr/local/www|/usr/local/apache/share),${PREFIX}/www,g' ${WRKSRC}/install.pl
- @${PERL} -pi -e 's,/usr/local/bin/ftplocate,${PREFIX}/bin/ftplocate,g' ${WRKSRC}/install.pl
- @${PERL} -pi -e 's,htdocs,data,g' ${WRKSRC}/install.pl
+ @${REINPLACE_CMD} -i '' -e 's|/usr/local/www|${PREFIX}/www|' \
+ -e 's|/usr/local/apache/share|${PREFIX}/www|' ${WRKSRC}/install.pl
+ @${REINPLACE_CMD} -i '' -e 's|/usr/local/bin/ftplocate|${PREFIX}/bin/ftplocate|' \
+ -e 's|htdocs|data|' -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/install.pl
do-install:
@${MKDIR} ${PREFIX}/www/data ${PREFIX}/www/cgi-bin
diff --git a/ftp/ftpmirror/Makefile b/ftp/ftpmirror/Makefile
index 92d6f5270f54..e0f2da9378b7 100644
--- a/ftp/ftpmirror/Makefile
+++ b/ftp/ftpmirror/Makefile
@@ -18,15 +18,15 @@ USE_PERL5= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
+USES= shebangfix
+SHEBANG_FILES= ftpmirror rotate
+
CONFIGURE_ENV+= PERL="${PERL}" INSTALL_PROGRAM="${INSTALL_SCRIPT}"
PORTDOCS= README.jis RELEASE.jis
post-configure:
- @${PERL} -i.bak -pe 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/Fan/Fan.pm
-.for f in ftpmirror rotate
- @${PERL} -i.bak -pe 's,^#!.*$$,#!${PERL}, if $$. == 1' ${WRKSRC}/${f}
-.endfor
+ @${REINPLACE_CMD} -i '' -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/Fan/Fan.pm
.include <bsd.port.pre.mk>