aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-05 14:44:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-05 14:44:11 +0000
commit0d9cd53bf08cd70f82b3542ee2cf56a8972dc05a (patch)
tree6a4b32a9ef4d7402ca9e34186b887561b256f11b /ftp
parent79afaab21e33dc8095f32c9dcb0606cd603e0721 (diff)
downloadports-0d9cd53bf08cd70f82b3542ee2cf56a8972dc05a.tar.gz
ports-0d9cd53bf08cd70f82b3542ee2cf56a8972dc05a.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/lftp/Makefile13
-rw-r--r--ftp/lftp/distinfo6
-rw-r--r--ftp/lftp/files/patch-lib-Makefile.in41
-rw-r--r--ftp/lftp/files/patch-ltmain.sh6
-rw-r--r--ftp/lftp/files/patch-src_Makefile.in6
-rw-r--r--ftp/lftp/pkg-plist4
6 files changed, 62 insertions, 14 deletions
diff --git a/ftp/lftp/Makefile b/ftp/lftp/Makefile
index 27436691293c..62a6e0826d91 100644
--- a/ftp/lftp/Makefile
+++ b/ftp/lftp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lftp
-PORTVERSION= 3.7.1
+PORTVERSION= 3.7.3
CATEGORIES= ftp ipv6
MASTER_SITES= ftp://ftp.wiretapped.net/pub/mirrors/lftp/ \
ftp://ftp.wiretapped.net/pub/mirrors/lftp/old/ \
@@ -20,7 +20,7 @@ MASTER_SITES= ftp://ftp.wiretapped.net/pub/mirrors/lftp/ \
http://lftp.cybermirror.org/ \
http://lftp.cybermirror.org/old/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ganael.laplanche@martymac.com
COMMENT= Shell-like command line ftp client
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
@@ -48,20 +48,25 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/libreadline.so.5:${PORTSDIR}/devel/readline
.endif
.if defined(WITH_GNUTLS)
-CONFIGURE_ARGS+= --with-gnutls
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+CONFIGURE_ARGS+= --with-gnutls
+.else
+CONFIGURE_ARGS+= --without-gnutls
.endif
.if !defined(WITHOUT_OPENSSL)
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS+= --with-openssl
+.else
+CONFIGURE_ARGS+= --without-openssl
.endif
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
+CONFIGURE_ARGS+= --enable-nls
PLIST_SUB+= NLS=""
.else
-CONFIGURE_ARGS+=--disable-nls
+CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
diff --git a/ftp/lftp/distinfo b/ftp/lftp/distinfo
index f51834c6c2d5..90ff2462c938 100644
--- a/ftp/lftp/distinfo
+++ b/ftp/lftp/distinfo
@@ -1,3 +1,3 @@
-MD5 (lftp-3.7.1.tar.bz2) = 60bb61fc1a5e96392bbd2dc88b938109
-SHA256 (lftp-3.7.1.tar.bz2) = a91b411acd3e1df394a8340a8ce0352795486cbc032e49d7093dc6a9cfb42864
-SIZE (lftp-3.7.1.tar.bz2) = 1165288
+MD5 (lftp-3.7.3.tar.bz2) = fc98506620b059d712341d624eb720d6
+SHA256 (lftp-3.7.3.tar.bz2) = f81d70b148d1f460658dad8a48b21b8ed918f60211770299151b64c8e49edfcf
+SIZE (lftp-3.7.3.tar.bz2) = 1315201
diff --git a/ftp/lftp/files/patch-lib-Makefile.in b/ftp/lftp/files/patch-lib-Makefile.in
new file mode 100644
index 000000000000..7543ca708df3
--- /dev/null
+++ b/ftp/lftp/files/patch-lib-Makefile.in
@@ -0,0 +1,41 @@
+--- lib/Makefile.in.orig 2008-05-23 15:54:06.000000000 +0200
++++ lib/Makefile.in 2008-05-28 17:40:42.280514020 +0200
+@@ -576,8 +576,6 @@
+ libgnu_la_LDFLAGS = $(AM_LDFLAGS)
+ GPERF = gperf
+ LINK_WARNING_H = $(top_srcdir)/build-aux/link-warning.h
+-charset_alias = $(DESTDIR)$(libdir)/charset.alias
+-charset_tmp = $(DESTDIR)$(libdir)/charset.tmp
+ all: $(BUILT_SOURCES) config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-am
+
+@@ -1107,29 +1105,8 @@
+ all-local: charset.alias ref-add.sed ref-del.sed
+ install-exec-local: all-local
+ test $(GLIBC21) != no || $(mkinstalldirs) $(DESTDIR)$(libdir)
+- if test -f $(charset_alias); then \
+- sed -f ref-add.sed $(charset_alias) > $(charset_tmp) ; \
+- $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
+- rm -f $(charset_tmp) ; \
+- else \
+- if test $(GLIBC21) = no; then \
+- sed -f ref-add.sed charset.alias > $(charset_tmp) ; \
+- $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
+- rm -f $(charset_tmp) ; \
+- fi ; \
+- fi
+
+ uninstall-local: all-local
+- if test -f $(charset_alias); then \
+- sed -f ref-del.sed $(charset_alias) > $(charset_tmp); \
+- if grep '^# Packages using this file: $$' $(charset_tmp) \
+- > /dev/null; then \
+- rm -f $(charset_alias); \
+- else \
+- $(INSTALL_DATA) $(charset_tmp) $(charset_alias); \
+- fi; \
+- rm -f $(charset_tmp); \
+- fi
+
+ charset.alias: config.charset
+ rm -f t-$@ $@
diff --git a/ftp/lftp/files/patch-ltmain.sh b/ftp/lftp/files/patch-ltmain.sh
index e48070bce0b6..c1bb71f5de01 100644
--- a/ftp/lftp/files/patch-ltmain.sh
+++ b/ftp/lftp/files/patch-ltmain.sh
@@ -1,6 +1,6 @@
---- ltmain.sh.orig Fri May 23 15:22:56 2003
-+++ ltmain.sh Thu May 27 12:50:36 2004
-@@ -5425,10 +5425,12 @@
+--- build-aux/ltmain.sh.orig 2007-12-29 12:41:13.000000000 +0100
++++ build-aux/ltmain.sh 2008-05-28 16:41:23.818197162 +0200
+@@ -6058,10 +6058,12 @@
fi
# Install the pseudo-library for information purposes.
diff --git a/ftp/lftp/files/patch-src_Makefile.in b/ftp/lftp/files/patch-src_Makefile.in
index db1ecaf7d909..2d641d7252c5 100644
--- a/ftp/lftp/files/patch-src_Makefile.in
+++ b/ftp/lftp/files/patch-src_Makefile.in
@@ -1,6 +1,6 @@
---- src/Makefile.in.orig Thu Dec 23 15:03:41 2004
-+++ src/Makefile.in Thu Dec 23 15:06:20 2004
-@@ -834,7 +834,7 @@
+--- src/Makefile.in.orig 2008-05-23 15:54:07.000000000 +0200
++++ src/Makefile.in 2008-05-28 16:41:23.857301294 +0200
+@@ -1217,7 +1217,7 @@
info-am:
diff --git a/ftp/lftp/pkg-plist b/ftp/lftp/pkg-plist
index c3b85db9db9e..a0e6ed3eadae 100644
--- a/ftp/lftp/pkg-plist
+++ b/ftp/lftp/pkg-plist
@@ -9,6 +9,7 @@ lib/liblftp-tasks.a
%%DATADIR%%/import-ncftp
%%DATADIR%%/import-netscape
%%DATADIR%%/verify-file
+@dirrm %%DATADIR%%
%%NLS%%share/locale/de/LC_MESSAGES/lftp.mo
%%NLS%%share/locale/es/LC_MESSAGES/lftp.mo
%%NLS%%share/locale/fr/LC_MESSAGES/lftp.mo
@@ -21,4 +22,5 @@ lib/liblftp-tasks.a
%%NLS%%share/locale/zh_CN/LC_MESSAGES/lftp.mo
%%NLS%%share/locale/zh_HK/LC_MESSAGES/lftp.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/lftp.mo
-@dirrm %%DATADIR%%
+%%NLS%%@dirrmtry share/locale/zh_HK/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/zh_HK