aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2017-09-26 15:29:22 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2017-09-26 15:29:22 +0000
commit601f1f848b1d10551750251b136e470c3ccbca4b (patch)
treeee1f1be3d3b71a4d356bcc9dd7c7cf660868dbf7 /ftp
parent2d4bdc7b138f2da943ed8ff9bf070f8e63775214 (diff)
downloadports-601f1f848b1d10551750251b136e470c3ccbca4b.tar.gz
ports-601f1f848b1d10551750251b136e470c3ccbca4b.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/lftp/Makefile2
-rw-r--r--ftp/lftp/distinfo6
-rw-r--r--ftp/lftp/files/patch-src-PollVec.cc15
3 files changed, 4 insertions, 19 deletions
diff --git a/ftp/lftp/Makefile b/ftp/lftp/Makefile
index fada04ec8a06..6ce623604e5f 100644
--- a/ftp/lftp/Makefile
+++ b/ftp/lftp/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lftp
-PORTVERSION= 4.8.1
+PORTVERSION= 4.8.2
CATEGORIES= ftp ipv6
MASTER_SITES= http://lftp.tech/ftp/ \
http://lftp.tech/ftp/old/ \
diff --git a/ftp/lftp/distinfo b/ftp/lftp/distinfo
index a11556d4772c..7a51fa10a209 100644
--- a/ftp/lftp/distinfo
+++ b/ftp/lftp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1505324333
-SHA256 (lftp-4.8.1.tar.gz) = 6117866215cd889dab30ff73292cd1d35fe0e12a9af5cd76d093500d07ab65a3
-SIZE (lftp-4.8.1.tar.gz) = 2825304
+TIMESTAMP = 1506421908
+SHA256 (lftp-4.8.2.tar.gz) = 9b21261faaa05d4fd235589cc21e2e45fc14c9314d7b4bb1f1aec44ea39eb3ee
+SIZE (lftp-4.8.2.tar.gz) = 2824498
diff --git a/ftp/lftp/files/patch-src-PollVec.cc b/ftp/lftp/files/patch-src-PollVec.cc
deleted file mode 100644
index 867af39ab487..000000000000
--- a/ftp/lftp/files/patch-src-PollVec.cc
+++ /dev/null
@@ -1,15 +0,0 @@
-Fix build on i386 [1]
-
-[1] https://lists.freebsd.org/pipermail/freebsd-pkg-fallout/Week-of-Mon-20170911/539371.html
-
---- ./src/PollVec.cc.orig 2017-09-16 22:29:12.266876000 +0200
-+++ ./src/PollVec.cc 2017-09-16 22:31:49.303761000 +0200
-@@ -30,7 +30,7 @@
-
- void PollVec::AddTimeoutU(unsigned t)
- {
-- struct timeval new_timeout={t/1000000,t%1000000};
-+ struct timeval new_timeout={static_cast<time_t>(t/1000000),static_cast<suseconds_t>(t%1000000)};
- if(tv_timeout.tv_sec<0 || new_timeout<tv_timeout)
- SetTimeout(new_timeout);
- }