aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2003-04-19 21:06:54 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2003-04-19 21:06:54 +0000
commit682c399f7c51aaf141976705010f4faf2aa5176d (patch)
tree8e7c7b569f0749b9cbb5ff8d876ee1459f5828b9 /ftp
parenta22769375b7a96ead063f4449b8550b84f6d97f2 (diff)
downloadports-682c399f7c51aaf141976705010f4faf2aa5176d.tar.gz
ports-682c399f7c51aaf141976705010f4faf2aa5176d.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/prozilla/Makefile41
-rw-r--r--ftp/prozilla/distinfo1
-rw-r--r--ftp/prozilla/files/patch-connect.c29
-rw-r--r--ftp/prozilla/files/patch-connection.c15
-rw-r--r--ftp/prozilla/files/patch-ftp-retr.c10
-rw-r--r--ftp/prozilla/files/patch-ftpsearch.c10
-rw-r--r--ftp/prozilla/files/patch-http-retr.c10
-rw-r--r--ftp/prozilla/files/patch-misc.c10
-rw-r--r--ftp/prozilla/files/patch-ping.c10
-rw-r--r--ftp/prozilla/pkg-descr17
-rw-r--r--ftp/prozilla/pkg-plist13
12 files changed, 167 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index a7f3319cc5d4..619d74806835 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -59,6 +59,7 @@
SUBDIR += pftpd
SUBDIR += proftpd
SUBDIR += profxp
+ SUBDIR += prozilla
SUBDIR += puf
SUBDIR += pure-ftpd
SUBDIR += py-curl
diff --git a/ftp/prozilla/Makefile b/ftp/prozilla/Makefile
new file mode 100644
index 000000000000..c632a0c7502e
--- /dev/null
+++ b/ftp/prozilla/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: ftp/prozilla
+# Date created: Jan 24 2003
+# Whom: Juan Salaverria <rael@vectorstar.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= prozilla
+PORTVERSION= 1.3.6
+CATEGORIES= ftp
+MASTER_SITES= http://prozilla.genesys.ro/downloads/prozilla/tarballs/
+
+MAINTAINER= rael@vectorstar.net
+COMMENT= ProZilla is a fast download accelerator
+
+LIB_DEPENDS= ncurses.5:${PORTSDIR}/devel/ncurses \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+
+MAN1= proz.1 prozilla.1
+
+DOCS= ANNOUNCE AUTHORS COPYING CREDITS ChangeLog INSTALL FAQ NEWS README TODO
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/ftp/prozilla/distinfo b/ftp/prozilla/distinfo
new file mode 100644
index 000000000000..f17a56cb0d3b
--- /dev/null
+++ b/ftp/prozilla/distinfo
@@ -0,0 +1 @@
+MD5 (prozilla-1.3.6.tar.gz) = 65864dfe72f5cb7d7e595ca6f34fc7d7
diff --git a/ftp/prozilla/files/patch-connect.c b/ftp/prozilla/files/patch-connect.c
new file mode 100644
index 000000000000..3c9589aafc3e
--- /dev/null
+++ b/ftp/prozilla/files/patch-connect.c
@@ -0,0 +1,29 @@
+--- src/connect.c.orig Fri Aug 17 20:38:25 2001
++++ src/connect.c Sat Jan 25 19:38:06 2003
+@@ -27,6 +27,7 @@
+ #include <sys/socket.h>
+ #include <fcntl.h>
+ #include <netdb.h>
++#include <netinet/in_systm.h>
+ #include <netinet/in.h>
+ #include <netinet/ip.h>
+ #include <netdb.h>
+@@ -341,6 +342,8 @@
+ struct hostent *hp;
+ int herr,res;
+
++#ifndef __FreeBSD__
++
+ if (*hstbuflen == 0)
+ {
+ *hstbuflen = 2048;
+@@ -364,5 +367,9 @@
+ }
+ if (res)
+ return NULL;
++#else
++ hp = gethostbyname(host);
++#endif
++
+ return hp;
+ }
diff --git a/ftp/prozilla/files/patch-connection.c b/ftp/prozilla/files/patch-connection.c
new file mode 100644
index 000000000000..9edd9e1053fe
--- /dev/null
+++ b/ftp/prozilla/files/patch-connection.c
@@ -0,0 +1,15 @@
+--- src/connection.c.ori Sat Jan 25 00:33:14 2003
++++ src/connection.c Sat Jan 25 00:33:38 2003
+@@ -30,7 +30,12 @@
+ #include <assert.h>
+ #include <pthread.h>
+
++#ifdef __FreeBSD__
++#include <sys/param.h>
++#include <sys/mount.h>
++#else
+ #include <sys/vfs.h>
++#endif
+
+ #include "connection.h"
+ #include "misc.h"
diff --git a/ftp/prozilla/files/patch-ftp-retr.c b/ftp/prozilla/files/patch-ftp-retr.c
new file mode 100644
index 000000000000..516fefbf4e47
--- /dev/null
+++ b/ftp/prozilla/files/patch-ftp-retr.c
@@ -0,0 +1,10 @@
+--- src/ftp-retr.c.ori Sat Jan 25 00:40:45 2003
++++ src/ftp-retr.c Sat Jan 25 00:40:56 2003
+@@ -32,6 +32,7 @@
+ #include <netdb.h>
+ #include <sys/socket.h>
+ #include <sys/time.h>
++#include <netinet/in_systm.h>
+ #include <netinet/in.h>
+ #include <netinet/ip.h>
+ #include <netinet/tcp.h>
diff --git a/ftp/prozilla/files/patch-ftpsearch.c b/ftp/prozilla/files/patch-ftpsearch.c
new file mode 100644
index 000000000000..c5ecb09902dc
--- /dev/null
+++ b/ftp/prozilla/files/patch-ftpsearch.c
@@ -0,0 +1,10 @@
+--- src/ftpsearch.c.ori Sat Jan 25 00:45:38 2003
++++ src/ftpsearch.c Sat Jan 25 00:45:48 2003
+@@ -25,6 +25,7 @@
+ #include <sys/socket.h>
+ #include <fcntl.h>
+ #include <netdb.h>
++#include <netinet/in_systm.h>
+ #include <netinet/in.h>
+ #include <netinet/ip.h>
+ #include <arpa/inet.h>
diff --git a/ftp/prozilla/files/patch-http-retr.c b/ftp/prozilla/files/patch-http-retr.c
new file mode 100644
index 000000000000..ff51af07226f
--- /dev/null
+++ b/ftp/prozilla/files/patch-http-retr.c
@@ -0,0 +1,10 @@
+--- src/http-retr.c.ori Sat Jan 25 00:49:21 2003
++++ src/http-retr.c Sat Jan 25 00:49:34 2003
+@@ -32,6 +32,7 @@
+ #include <fcntl.h>
+ #include <sys/socket.h>
+ #include <sys/time.h>
++#include <netinet/in_systm.h>
+ #include <netinet/in.h>
+ #include <netinet/ip.h>
+ #include <netinet/tcp.h>
diff --git a/ftp/prozilla/files/patch-misc.c b/ftp/prozilla/files/patch-misc.c
new file mode 100644
index 000000000000..20298f17aa85
--- /dev/null
+++ b/ftp/prozilla/files/patch-misc.c
@@ -0,0 +1,10 @@
+--- src/misc.c.ori Sat Jan 25 01:38:04 2003
++++ src/misc.c Sat Jan 25 01:38:40 2003
+@@ -24,7 +24,6 @@
+ #include <stdio.h>
+ #include <stdarg.h>
+ #include <stdlib.h>
+-#include <malloc.h>
+ #include <string.h>
+ #include <ctype.h>
+ #include <curses.h>
diff --git a/ftp/prozilla/files/patch-ping.c b/ftp/prozilla/files/patch-ping.c
new file mode 100644
index 000000000000..d095e3988695
--- /dev/null
+++ b/ftp/prozilla/files/patch-ping.c
@@ -0,0 +1,10 @@
+--- src/ping.c.ori Sat Jan 25 00:53:13 2003
++++ src/ping.c Sat Jan 25 00:53:28 2003
+@@ -23,6 +23,7 @@
+ #include <sys/socket.h>
+ #include <fcntl.h>
+ #include <netdb.h>
++#include <netinet/in_systm.h>
+ #include <netinet/in.h>
+ #include <netinet/ip.h>
+ #include <arpa/inet.h>
diff --git a/ftp/prozilla/pkg-descr b/ftp/prozilla/pkg-descr
new file mode 100644
index 000000000000..4878e1a1ce6c
--- /dev/null
+++ b/ftp/prozilla/pkg-descr
@@ -0,0 +1,17 @@
+ProZilla is a download accelerator for Linux which gives you
+a 200% to 300% improvement in your file downloading speeds.
+
+Its features:
+
+ * Supports FTP & HTTP including redirection
+ * Resume Supported
+ * Complete acceleration: The file will be downloaded as fast as
+ possible as your bandwidth allows if not otherwise specified
+ * Unlike certain other download accelerators available for Linux,
+ this really works.
+ * The number of connections that prozilla uses can be specified
+ * FTPsearch support now permits fetching Mirror locations and
+ pinging them and selecting the fastest server is automatically
+ done
+
+WWW: http://prozilla.genesys.ro/
diff --git a/ftp/prozilla/pkg-plist b/ftp/prozilla/pkg-plist
new file mode 100644
index 000000000000..d17be6bbb243
--- /dev/null
+++ b/ftp/prozilla/pkg-plist
@@ -0,0 +1,13 @@
+bin/proz
+etc/prozilla.conf-sample
+%%PORTDOCS%%share/doc/prozilla/ANNOUNCE
+%%PORTDOCS%%share/doc/prozilla/AUTHORS
+%%PORTDOCS%%share/doc/prozilla/COPYING
+%%PORTDOCS%%share/doc/prozilla/CREDITS
+%%PORTDOCS%%share/doc/prozilla/ChangeLog
+%%PORTDOCS%%share/doc/prozilla/FAQ
+%%PORTDOCS%%share/doc/prozilla/INSTALL
+%%PORTDOCS%%share/doc/prozilla/NEWS
+%%PORTDOCS%%share/doc/prozilla/README
+%%PORTDOCS%%share/doc/prozilla/TODO
+%%PORTDOCS%%@dirrm share/doc/prozilla