aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-07 23:13:45 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-07 23:13:45 +0000
commit2ca07b88c97e4bcce2d19264531201d38a8fa62b (patch)
treea833770401a06ed63ca12e3ac4a612f894591f71 /ftp
parent61e495339372e204a4258ce2a34193a26651f558 (diff)
downloadports-2ca07b88c97e4bcce2d19264531201d38a8fa62b.tar.gz
ports-2ca07b88c97e4bcce2d19264531201d38a8fa62b.zip
Update to 7.64.0
Changes: https://curl.haxx.se/changes.html Security: 714b033a-2b09-11e9-8bc3-610fd6e6cd05 MFH: 2019Q1
Notes
Notes: svn path=/head/; revision=492389
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile6
-rw-r--r--ftp/curl/distinfo6
-rw-r--r--ftp/curl/files/patch-configure20
-rw-r--r--ftp/curl/files/patch-lib-url.c4
-rw-r--r--ftp/curl/files/patch-lib-vtls-openssl.c4
-rw-r--r--ftp/curl/pkg-plist3
6 files changed, 22 insertions, 21 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 35091ae215fa..a38747636268 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= curl
-PORTVERSION= 7.63.0
-PORTREVISION= 1
+PORTVERSION= 7.64.0
CATEGORIES= ftp net www
MASTER_SITES= https://curl.haxx.se/download/ \
LOCAL/sunpoet
@@ -47,8 +46,7 @@ USES= cpe gmake libtool localbase pathfix perl5 shebangfix tar:xz
USE_PERL5= build
CONFIGURE_ARGS= --disable-werror \
- --with-zsh-functions-dir=${LOCALBASE}/share/zsh/site-functions \
- --without-axtls
+ --with-zsh-functions-dir=${LOCALBASE}/share/zsh/site-functions
CONFIGURE_ENV= LOCALBASE=${LOCALBASE} \
ac_cv_func_SSLv2_client_method=no
GNU_CONFIGURE= yes
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index c767e7a5d583..d2233a9c42e0 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1546194081
-SHA256 (curl-7.63.0.tar.xz) = 9600234c794bfb8a0d3f138e9294d60a20e7a5f10e35ece8cf518e2112d968c4
-SIZE (curl-7.63.0.tar.xz) = 2390408
+TIMESTAMP = 1549565147
+SHA256 (curl-7.64.0.tar.xz) = 2f2f13fa34d44aa29cb444077ad7dc4dc6d189584ad552e0aaeb06e608af6001
+SIZE (curl-7.64.0.tar.xz) = 2398904
diff --git a/ftp/curl/files/patch-configure b/ftp/curl/files/patch-configure
index 9e73d736dddb..540198a050c2 100644
--- a/ftp/curl/files/patch-configure
+++ b/ftp/curl/files/patch-configure
@@ -6,9 +6,9 @@ Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2010-12-19
---- configure.orig 2018-10-30 10:03:34 UTC
+--- configure.orig 2019-02-05 14:11:44 UTC
+++ configure
-@@ -3652,9 +3652,10 @@ $as_echo "$as_me: LIBS note: LIBS should
+@@ -3637,9 +3637,10 @@ $as_echo "$as_me: LIBS note: LIBS should
-I*)
xc_bad_var_ldflags=yes
;;
@@ -22,7 +22,7 @@ Last-Update: 2010-12-19
esac
done
if test $xc_bad_var_ldflags = yes; then
-@@ -3724,9 +3725,10 @@ $as_echo "$as_me: $xc_bad_var_msg librar
+@@ -3709,9 +3710,10 @@ $as_echo "$as_me: $xc_bad_var_msg librar
xc_bad_var_cflags=no
for xc_word in $CFLAGS; do
case "$xc_word" in
@@ -36,7 +36,7 @@ Last-Update: 2010-12-19
-U*)
xc_bad_var_cflags=yes
;;
-@@ -17364,6 +17366,8 @@ $as_echo "$as_me: WARNING: compiler opti
+@@ -17193,6 +17195,8 @@ $as_echo "$as_me: WARNING: compiler opti
tmp_CFLAGS="$CFLAGS"
tmp_CPPFLAGS="$CPPFLAGS"
@@ -45,7 +45,7 @@ Last-Update: 2010-12-19
ac_var_stripped=""
for word1 in $tmp_CFLAGS; do
ac_var_strip_word="no"
-@@ -17394,6 +17398,7 @@ $as_echo "$as_me: WARNING: compiler opti
+@@ -17223,6 +17227,7 @@ $as_echo "$as_me: WARNING: compiler opti
done
tmp_CPPFLAGS="$ac_var_stripped"
squeeze tmp_CPPFLAGS
@@ -53,7 +53,7 @@ Last-Update: 2010-12-19
#
if test "$want_debug" = "yes"; then
-@@ -17616,6 +17621,8 @@ $as_echo "$honor_optimize_option" >&6; }
+@@ -17445,6 +17450,8 @@ $as_echo "$honor_optimize_option" >&6; }
#
if test "$honor_optimize_option" = "yes"; then
@@ -62,7 +62,7 @@ Last-Update: 2010-12-19
ac_var_stripped=""
for word1 in $tmp_CFLAGS; do
ac_var_strip_word="no"
-@@ -17646,6 +17653,7 @@ $as_echo "$honor_optimize_option" >&6; }
+@@ -17475,6 +17482,7 @@ $as_echo "$honor_optimize_option" >&6; }
done
tmp_CPPFLAGS="$ac_var_stripped"
squeeze tmp_CPPFLAGS
@@ -70,7 +70,7 @@ Last-Update: 2010-12-19
if test "$want_optimize" = "yes"; then
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if compiler accepts optimizer enabling options" >&5
-@@ -26970,30 +26978,30 @@ $as_echo "found" >&6; }
+@@ -26706,30 +26714,30 @@ $as_echo "found" >&6; }
;;
off)
LIB_RTMP="-lrtmp"
@@ -110,7 +110,7 @@ Last-Update: 2010-12-19
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-@@ -41444,9 +41452,10 @@ $as_echo "$as_me: LIBS note: LIBS should
+@@ -41169,9 +41177,10 @@ $as_echo "$as_me: LIBS note: LIBS should
-I*)
xc_bad_var_ldflags=yes
;;
@@ -124,7 +124,7 @@ Last-Update: 2010-12-19
esac
done
if test $xc_bad_var_ldflags = yes; then
-@@ -41516,9 +41525,10 @@ $as_echo "$as_me: $xc_bad_var_msg librar
+@@ -41241,9 +41250,10 @@ $as_echo "$as_me: $xc_bad_var_msg librar
xc_bad_var_cflags=no
for xc_word in $CFLAGS; do
case "$xc_word" in
diff --git a/ftp/curl/files/patch-lib-url.c b/ftp/curl/files/patch-lib-url.c
index 1618ec1285c1..f58cbde71101 100644
--- a/ftp/curl/files/patch-lib-url.c
+++ b/ftp/curl/files/patch-lib-url.c
@@ -3,7 +3,7 @@ Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2010-12-18
---- lib/url.c.orig 2018-10-30 06:47:16 UTC
+--- lib/url.c.orig 2019-02-05 14:00:12 UTC
+++ lib/url.c
@@ -536,6 +536,10 @@ CURLcode Curl_init_userdefined(struct Cu
set->fnmatch = ZERO_NULL;
@@ -13,6 +13,6 @@ Last-Update: 2010-12-18
+ /* different handling of signals and threads */
+ set->no_signal = TRUE;
+#endif
+ set->http09_allowed = TRUE;
set->httpversion =
#ifdef USE_NGHTTP2
- CURL_HTTP_VERSION_2TLS
diff --git a/ftp/curl/files/patch-lib-vtls-openssl.c b/ftp/curl/files/patch-lib-vtls-openssl.c
index d41f50c454c9..5ffbe4afb567 100644
--- a/ftp/curl/files/patch-lib-vtls-openssl.c
+++ b/ftp/curl/files/patch-lib-vtls-openssl.c
@@ -1,6 +1,6 @@
---- lib/vtls/openssl.c.orig 2018-10-27 13:34:01 UTC
+--- lib/vtls/openssl.c.orig 2019-02-05 14:00:12 UTC
+++ lib/vtls/openssl.c
-@@ -3715,7 +3715,11 @@ static size_t Curl_ossl_version(char *bu
+@@ -3785,7 +3785,11 @@ static size_t Curl_ossl_version(char *bu
unsigned long ssleay_value;
sub[2]='\0';
sub[1]='\0';
diff --git a/ftp/curl/pkg-plist b/ftp/curl/pkg-plist
index 21feed30685b..07c6a9bca2f7 100644
--- a/ftp/curl/pkg-plist
+++ b/ftp/curl/pkg-plist
@@ -168,6 +168,7 @@ man/man3/CURLOPT_HEADER.3.gz
man/man3/CURLOPT_HEADERDATA.3.gz
man/man3/CURLOPT_HEADERFUNCTION.3.gz
man/man3/CURLOPT_HEADEROPT.3.gz
+man/man3/CURLOPT_HTTP09_ALLOWED.3.gz
man/man3/CURLOPT_HTTP200ALIASES.3.gz
man/man3/CURLOPT_HTTPAUTH.3.gz
man/man3/CURLOPT_HTTPGET.3.gz
@@ -338,6 +339,8 @@ man/man3/CURLOPT_TLS13_CIPHERS.3.gz
man/man3/CURLOPT_TLSAUTH_PASSWORD.3.gz
man/man3/CURLOPT_TLSAUTH_TYPE.3.gz
man/man3/CURLOPT_TLSAUTH_USERNAME.3.gz
+man/man3/CURLOPT_TRAILERDATA.3.gz
+man/man3/CURLOPT_TRAILERFUNCTION.3.gz
man/man3/CURLOPT_TRANSFERTEXT.3.gz
man/man3/CURLOPT_TRANSFER_ENCODING.3.gz
man/man3/CURLOPT_UNIX_SOCKET_PATH.3.gz