aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-05-31 10:27:54 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-05-31 10:27:54 +0000
commit689c2d7d378e7067b4c3f0b270468ac612f180d5 (patch)
tree4d3a593f54ce556529e82b1b6a5db61b7b797dfa /ftp
parent84301a088e0f14cd8cfde8b99e280899047070d4 (diff)
downloadports-689c2d7d378e7067b4c3f0b270468ac612f180d5.tar.gz
ports-689c2d7d378e7067b4c3f0b270468ac612f180d5.zip
Fix runtime with OpenSSL without MD4
- Bump PORTREVISION for package change Obtained from: https://github.com/curl/curl/commit/0dc9a8019962d31787c4929d36de6817ae3090e7
Notes
Notes: svn path=/head/; revision=503135
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile2
-rw-r--r--ftp/curl/files/patch-lib-md4.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index bc325fe114d5..dd326a3fdbe7 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= curl
PORTVERSION= 7.65.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= ftp net www
MASTER_SITES= https://curl.haxx.se/download/ \
LOCAL/sunpoet
diff --git a/ftp/curl/files/patch-lib-md4.c b/ftp/curl/files/patch-lib-md4.c
new file mode 100644
index 000000000000..441adabe1703
--- /dev/null
+++ b/ftp/curl/files/patch-lib-md4.c
@@ -0,0 +1,15 @@
+Obtained from: https://github.com/curl/curl/commit/0dc9a8019962d31787c4929d36de6817ae3090e7
+
+--- lib/md4.c.orig 2019-05-20 08:13:23 UTC
++++ lib/md4.c
+@@ -38,6 +38,10 @@
+
+ #include "curl_setup.h"
+
++#ifdef USE_OPENSSL
++#include <openssl/opensslconf.h>
++#endif
++
+ /* The NSS, OS/400, and when not included, OpenSSL and mbed TLS crypto
+ * libraries do not provide the MD4 hash algorithm, so we use this
+ * implementation of it */