aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-07-31 11:56:17 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-07-31 11:56:17 +0000
commita74217e6d9281b3d195ab0ad6e6b9434f63b6d27 (patch)
tree44a97c66747f24c5fab92020a97ab60bb4e93db7 /ftp
parente4ceaa901bf22ed58f8d80e942449d482ccfbb7e (diff)
downloadports-a74217e6d9281b3d195ab0ad6e6b9434f63b6d27.tar.gz
ports-a74217e6d9281b3d195ab0ad6e6b9434f63b6d27.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/p5-File-Fetch/Makefile3
-rw-r--r--ftp/p5-Net-FTPSSL/Makefile9
-rw-r--r--ftp/p5-Net-FTPServer/Makefile3
-rw-r--r--ftp/p5-POE-Component-Client-FTP/Makefile3
-rw-r--r--ftp/paraget/Makefile10
-rw-r--r--ftp/profxp/Makefile4
-rw-r--r--ftp/wzdftpd/Makefile2
7 files changed, 14 insertions, 20 deletions
diff --git a/ftp/p5-File-Fetch/Makefile b/ftp/p5-File-Fetch/Makefile
index 34c829280272..830d3ed79c6e 100644
--- a/ftp/p5-File-Fetch/Makefile
+++ b/ftp/p5-File-Fetch/Makefile
@@ -13,7 +13,8 @@ COMMENT= Generic file fetching mechanism
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= File::Fetch.3
diff --git a/ftp/p5-Net-FTPSSL/Makefile b/ftp/p5-Net-FTPSSL/Makefile
index 19fc9400af56..1530ee40ff96 100644
--- a/ftp/p5-Net-FTPSSL/Makefile
+++ b/ftp/p5-Net-FTPSSL/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Net-FTPSSL
-# Date created: 1st Dec, 2010
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Net-FTPSSL
PORTVERSION= 0.22
@@ -18,7 +14,8 @@ BUILD_DEPENDS= p5-IO-Socket-SSL>=1.08:${PORTSDIR}/security/p5-IO-Socket-SSL \
p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::FTPSSL.3
diff --git a/ftp/p5-Net-FTPServer/Makefile b/ftp/p5-Net-FTPServer/Makefile
index b0f9d1ef8cfd..da1981a6fafa 100644
--- a/ftp/p5-Net-FTPServer/Makefile
+++ b/ftp/p5-Net-FTPServer/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-Archive-Zip>=0:${PORTSDIR}/archivers/p5-Archive-Zip \
BUILD_DEPENDS:= ${RUN_DEPENDS}
MAKE_ENV+= NOCONF=1
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
SUB_FILES= pkg-message
diff --git a/ftp/p5-POE-Component-Client-FTP/Makefile b/ftp/p5-POE-Component-Client-FTP/Makefile
index 2e1366a3d87e..c76a2a83bc05 100644
--- a/ftp/p5-POE-Component-Client-FTP/Makefile
+++ b/ftp/p5-POE-Component-Client-FTP/Makefile
@@ -13,7 +13,8 @@ COMMENT= Implements an FTP client POE Component
BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ENV= PERL_MM_USE_DEFAULT=yes
MAN3= POE::Component::Client::FTP.3
diff --git a/ftp/paraget/Makefile b/ftp/paraget/Makefile
index 6aeabe81a4e9..ea6efc3c2169 100644
--- a/ftp/paraget/Makefile
+++ b/ftp/paraget/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: paraget
-# Date created: Apr 18, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= paraget
PORTVERSION= 0.3.0
@@ -20,7 +15,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= paraget.1
diff --git a/ftp/profxp/Makefile b/ftp/profxp/Makefile
index 9206db9334e0..96484f76353d 100644
--- a/ftp/profxp/Makefile
+++ b/ftp/profxp/Makefile
@@ -11,15 +11,13 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION:S/p/-pre/}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= FXP (server-to-server FTP) client
-USE_PERL5= yes
-
RUN_DEPENDS= p5-SOCKS>=0:${PORTSDIR}/net/p5-Socks \
p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey \
p5-ReadLine-Perl>=0:${PORTSDIR}/devel/p5-ReadLine-Perl
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
-USES= shebangfix
+USES= shebangfix perl5
SHEBANG_FILES= profxpv3.pl
perl_OLD_CMD= /home/tom/ActivePerl-5.6/bin/perl
diff --git a/ftp/wzdftpd/Makefile b/ftp/wzdftpd/Makefile
index 86a71c330b27..9768578de99e 100644
--- a/ftp/wzdftpd/Makefile
+++ b/ftp/wzdftpd/Makefile
@@ -70,7 +70,7 @@ CONFIGURE_ARGS+= --disable-ipv6
.endif
.if ${PORT_OPTIONS:MPERL}
-USE_PERL5= yes
+USES+= perl5
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VER}
MAN3+= wzdftpd.3
PLIST_SUB+= PERL=""