aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2017-01-28 14:33:43 +0000
committerJohn Marino <marino@FreeBSD.org>2017-01-28 14:33:43 +0000
commitcc875c39f36c19fd9b071c11ac287d78a2382a55 (patch)
treec54ac8cd870752ad3ebe71de96401bf489c1630b /ftp
parent677146d9f200de2a963dc93cce0c284a4aeb4ab4 (diff)
downloadports-cc875c39f36c19fd9b071c11ac287d78a2382a55.tar.gz
ports-cc875c39f36c19fd9b071c11ac287d78a2382a55.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/fastdfs/files/patch-client-Makefile.in3
-rw-r--r--ftp/fastdfs/files/patch-storage-Makefile.in6
-rw-r--r--ftp/fastdfs/files/patch-tracker-Makefile.in6
3 files changed, 10 insertions, 5 deletions
diff --git a/ftp/fastdfs/files/patch-client-Makefile.in b/ftp/fastdfs/files/patch-client-Makefile.in
index 9d31939b16f8..1adae60f9b07 100644
--- a/ftp/fastdfs/files/patch-client-Makefile.in
+++ b/ftp/fastdfs/files/patch-client-Makefile.in
@@ -5,8 +5,9 @@
ENABLE_STATIC_LIB = $(ENABLE_STATIC_LIB)
ENABLE_SHARED_LIB = $(ENABLE_SHARED_LIB)
-INC_PATH = -I../common -I../tracker -I/usr/include/fastcommon
+-LIB_PATH = $(LIBS) -lfastcommon
+INC_PATH = -I../common -I../tracker -I$(LOCALBASE)/include/fastcommon
- LIB_PATH = $(LIBS) -lfastcommon
++LIB_PATH = $(LIBS) -L${LOCALBASE}/lib -lfastcommon
TARGET_PATH = $(TARGET_PREFIX)/bin
-TARGET_LIB = $(TARGET_PREFIX)/lib64
+TARGET_LIB = $(TARGET_PREFIX)/lib
diff --git a/ftp/fastdfs/files/patch-storage-Makefile.in b/ftp/fastdfs/files/patch-storage-Makefile.in
index 6db80da6b740..095b7f770cec 100644
--- a/ftp/fastdfs/files/patch-storage-Makefile.in
+++ b/ftp/fastdfs/files/patch-storage-Makefile.in
@@ -1,14 +1,16 @@
--- storage/Makefile.in.orig 2016-08-08 07:17:50 UTC
+++ storage/Makefile.in
-@@ -1,7 +1,7 @@
+@@ -1,8 +1,8 @@
.SUFFIXES: .c .o
COMPILE = $(CC) $(CFLAGS)
-INC_PATH = -I. -Itrunk_mgr -I../common -I../tracker -I../client -Ifdht_client -I/usr/include/fastcommon
+-LIB_PATH = $(LIBS) -lfastcommon
+INC_PATH = -I. -Itrunk_mgr -I../common -I../tracker -I../client -Ifdht_client -I$(LOCALBASE)/include/fastcommon
- LIB_PATH = $(LIBS) -lfastcommon
++LIB_PATH = $(LIBS) -L${LOCALBASE}/lib -lfastcommon
TARGET_PATH = $(TARGET_PREFIX)/bin
CONFIG_PATH = $(TARGET_CONF_PATH)
+
@@ -34,7 +34,7 @@ all: $(ALL_OBJS) $(ALL_PRGS)
install:
mkdir -p $(TARGET_PATH)
diff --git a/ftp/fastdfs/files/patch-tracker-Makefile.in b/ftp/fastdfs/files/patch-tracker-Makefile.in
index 1ee70efc45e5..01757c3a17f1 100644
--- a/ftp/fastdfs/files/patch-tracker-Makefile.in
+++ b/ftp/fastdfs/files/patch-tracker-Makefile.in
@@ -1,14 +1,16 @@
--- tracker/Makefile.in.orig 2016-08-08 07:17:50 UTC
+++ tracker/Makefile.in
-@@ -1,7 +1,7 @@
+@@ -1,8 +1,8 @@
.SUFFIXES: .c .o
COMPILE = $(CC) $(CFLAGS)
-INC_PATH = -I../common -I/usr/include/fastcommon
+-LIB_PATH = $(LIBS) -lfastcommon
+INC_PATH = -I../common -I$(LOCALBASE)/include/fastcommon
- LIB_PATH = $(LIBS) -lfastcommon
++LIB_PATH = $(LIBS) -L${LOCALBASE}/lib -lfastcommon
TARGET_PATH = $(TARGET_PREFIX)/bin
CONFIG_PATH = $(TARGET_CONF_PATH)
+
@@ -26,7 +26,8 @@ all: $(ALL_OBJS) $(ALL_PRGS)
install:
mkdir -p $(TARGET_PATH)