aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-05-26 20:01:07 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-05-26 20:01:07 +0000
commit370954b872a87e336f49b8be8f8670f378d24e41 (patch)
tree4e87a3bc8aae880cc94cfec333864922b40b83d4 /ftp
parent4573c14a07f67dcadc79f9a18958f6043eb0f130 (diff)
downloadports-370954b872a87e336f49b8be8f8670f378d24e41.tar.gz
ports-370954b872a87e336f49b8be8f8670f378d24e41.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/bftpd/Makefile6
-rw-r--r--ftp/bftpd/distinfo6
-rw-r--r--ftp/bftpd/files/patch-login.c12
-rw-r--r--ftp/bftpd/files/patch-main.c11
-rw-r--r--ftp/bftpd/files/patch-options.c11
-rw-r--r--ftp/bftpd/pkg-descr35
6 files changed, 43 insertions, 38 deletions
diff --git a/ftp/bftpd/Makefile b/ftp/bftpd/Makefile
index f289478a859b..0f8d28832177 100644
--- a/ftp/bftpd/Makefile
+++ b/ftp/bftpd/Makefile
@@ -6,15 +6,15 @@
#
PORTNAME= bftpd
-PORTVERSION= 1.6
+PORTVERSION= 1.8.4
CATEGORIES= ftp
-MASTER_SITES= SF
+MASTER_SITES= CENKES http://freebsd.alaskaparadise.com/source/ \
+ http://bftpd.sourceforge.net/downloads/testing/
MAINTAINER= beech@alaskaparadise.com
COMMENT= Very configurable FTP server that can do chroot easily
GNU_CONFIGURE= yes
-
CONFIGURE_ARGS+= --enable-pam
PLIST_FILES= sbin/${PORTNAME} etc/${PORTNAME}.conf.sample
diff --git a/ftp/bftpd/distinfo b/ftp/bftpd/distinfo
index f6e16259bc78..c8ef2ac0ac97 100644
--- a/ftp/bftpd/distinfo
+++ b/ftp/bftpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (bftpd-1.6.tar.gz) = 203ebbe285857a4b001d4a9872cffce4
-SHA256 (bftpd-1.6.tar.gz) = abbb20380f7ca4606e0e7d7586ad74d457b637839d560502e9547d8e91a2c986
-SIZE (bftpd-1.6.tar.gz) = 112303
+MD5 (bftpd-1.8.4.tar.gz) = dc97121eda9b93226899ff7c9ea5acf1
+SHA256 (bftpd-1.8.4.tar.gz) = 6375124e0f4709795b7fc8f499f70c28fb1c6d7312b3b88cbfc84d8e3712855c
+SIZE (bftpd-1.8.4.tar.gz) = 114815
diff --git a/ftp/bftpd/files/patch-login.c b/ftp/bftpd/files/patch-login.c
deleted file mode 100644
index 2d2a3bb5bb64..000000000000
--- a/ftp/bftpd/files/patch-login.c
+++ /dev/null
@@ -1,12 +0,0 @@
-$FreeBSD$
-
---- login.c.orig Thu Mar 28 10:10:15 2002
-+++ login.c Thu Mar 28 10:10:22 2002
-@@ -323,7 +323,6 @@
- pam_strerror(pamh, retval));
- return 1;
- }
-- pam_fail_delay(pamh, 0);
- retval = pam_authenticate(pamh, 0);
- if (retval == PAM_SUCCESS)
- retval = pam_acct_mgmt(pamh, 0);
diff --git a/ftp/bftpd/files/patch-main.c b/ftp/bftpd/files/patch-main.c
new file mode 100644
index 000000000000..9e035c0b9516
--- /dev/null
+++ b/ftp/bftpd/files/patch-main.c
@@ -0,0 +1,11 @@
+--- main.c.orig Sun Apr 8 12:34:59 2007
++++ main.c Thu May 24 19:11:45 2007
+@@ -47,6 +47,8 @@
+ # include <sys/wait.h>
+ # endif
+ #endif
++/* add BSD support */
++#include <limits.h>
+
+ #include "main.h"
+ #include "cwd.h"
diff --git a/ftp/bftpd/files/patch-options.c b/ftp/bftpd/files/patch-options.c
new file mode 100644
index 000000000000..3f18e8943aca
--- /dev/null
+++ b/ftp/bftpd/files/patch-options.c
@@ -0,0 +1,11 @@
+--- options.c.orig Fri Apr 13 16:19:15 2007
++++ options.c Thu May 24 19:13:39 2007
+@@ -3,6 +3,8 @@
+ #include <stdlib.h>
+ #include <grp.h>
+ #include <unistd.h>
++/* add BSD support */
++#include <limits.h>
+
+ #include "options.h"
+ #include "mystring.h"
diff --git a/ftp/bftpd/pkg-descr b/ftp/bftpd/pkg-descr
index 8a41711eda8f..06f7cb3da456 100644
--- a/ftp/bftpd/pkg-descr
+++ b/ftp/bftpd/pkg-descr
@@ -1,23 +1,18 @@
-bftpd is an FTP server for Linux, BSD/OS, FreeBSD, Solaris, DG-UX
-and Tru64. It runs either with inetd or standalone.
-
-It tries to be very configurable while being fast and small. You
-can make defaults for each configuration option, and then override
-these defaults in user-specific structures. Support for
-directory-specific options is planned.
+The Bftpd file server is designed to be as small and easy to manage as possible,
+while providing most of the features you would expect from a file server. On
+most home systems, bftpd is ready to work out-of-the-box without requiring any
+extra configuration. Production systems can be set up by editing a few lines in
+an easy-to-read config file.
Features of bftpd include:
- * Easy configuration
- * Speed
- * Support for most RFC FTP commands
- * tar.gz on-the-fly compression/archiving
- * Security with chroot without special setup
- * No need for files (sh, ls...) in a chroot environment
- * Logging to wtmp and to a config file
- * PAM support
- * Support for SITE CHOWN/CHMOD
-
-WWW: http://www.bftpd.org/
+* Easy configuration
+* Speed
+* Support for most RFC FTP commands
+* tar.gz on-the-fly compression/archiving
+* Security with chroot without special setup
+* No need for files (sh, ls...) in a chroot environment
+* Logging to wtmp and to a config file
+* PAM support
+* Support for site chown/chmod
-- Pete
-petef@databits.net
+WWW: http://bftpd.sourceforge.net/