aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-08-22 16:22:19 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-08-22 16:22:19 +0000
commit9eba8f55eac8d0f070f0d11200e7227c87031e85 (patch)
tree95b99143620e7ed99f0036621626edc39b8088b7 /ftp
parentb44c4436ff2106d0caf09d5f74821353003b33cf (diff)
downloadports-9eba8f55eac8d0f070f0d11200e7227c87031e85.tar.gz
ports-9eba8f55eac8d0f070f0d11200e7227c87031e85.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/p5-SOAP-Transport-FTP/Makefile30
-rw-r--r--ftp/p5-SOAP-Transport-FTP/distinfo2
-rw-r--r--ftp/p5-SOAP-Transport-FTP/pkg-descr6
-rw-r--r--ftp/p5-SOAP-Transport-FTP/pkg-plist7
5 files changed, 46 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index c29679accf51..73f4ff9e13d0 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -69,6 +69,7 @@
SUBDIR += p5-Net-FTPSSL
SUBDIR += p5-Net-FTPServer
SUBDIR += p5-POE-Component-Client-FTP
+ SUBDIR += p5-SOAP-Transport-FTP
SUBDIR += paraget
SUBDIR += pavuk
SUBDIR += pear-Net_FTP
diff --git a/ftp/p5-SOAP-Transport-FTP/Makefile b/ftp/p5-SOAP-Transport-FTP/Makefile
new file mode 100644
index 000000000000..2e8b1de36165
--- /dev/null
+++ b/ftp/p5-SOAP-Transport-FTP/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-SOAP-Transport-FTP
+# Date created: 2011-08-20
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SOAP-Transport-FTP
+PORTVERSION= 0.711
+CATEGORIES= ftp net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= FTP Client support for SOAP::Lite
+
+BUILD_DEPENDS= p5-SOAP-Lite>=0.711:${PORTSDIR}/net/p5-SOAP-Lite
+RUN_DEPENDS= p5-SOAP-Lite>=0.711:${PORTSDIR}/net/p5-SOAP-Lite
+
+PERL_CONFIGURE= yes
+
+MAN3= SOAP::Transport::FTP.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501200
+BUILD_DEPENDS+= p5-Module-Build>=0.3600:${PORTSDIR}/devel/p5-Module-Build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/ftp/p5-SOAP-Transport-FTP/distinfo b/ftp/p5-SOAP-Transport-FTP/distinfo
new file mode 100644
index 000000000000..333e4442f4da
--- /dev/null
+++ b/ftp/p5-SOAP-Transport-FTP/distinfo
@@ -0,0 +1,2 @@
+SHA256 (SOAP-Transport-FTP-0.711.tar.gz) = 3dfdece26a6e39b75e4ac99e5baec70a614b3374084edab78513ddac2017f40a
+SIZE (SOAP-Transport-FTP-0.711.tar.gz) = 34878
diff --git a/ftp/p5-SOAP-Transport-FTP/pkg-descr b/ftp/p5-SOAP-Transport-FTP/pkg-descr
new file mode 100644
index 000000000000..b1003ae0e592
--- /dev/null
+++ b/ftp/p5-SOAP-Transport-FTP/pkg-descr
@@ -0,0 +1,6 @@
+The SOAP::Transport::FTP module is automatically loaded by the SOAP::Transport
+portion of the client structure. It is brought in when an endpoint is specified
+via the proxy method that starts with the characters, ftp://. This module
+provides only a client class.
+
+WWW: http://search.cpan.org/dist/SOAP-Transport-FTP/
diff --git a/ftp/p5-SOAP-Transport-FTP/pkg-plist b/ftp/p5-SOAP-Transport-FTP/pkg-plist
new file mode 100644
index 000000000000..6887c7015681
--- /dev/null
+++ b/ftp/p5-SOAP-Transport-FTP/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/SOAP/Transport/FTP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP/Transport/FTP/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP/Transport/FTP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP/Transport
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP
+@dirrmtry %%SITE_PERL%%/SOAP/Transport
+@dirrmtry %%SITE_PERL%%/SOAP