aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-25 20:39:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-25 20:39:36 +0000
commit51fb72abd81c6f0e55cf42b4f8859d0d50355923 (patch)
tree334c31e3fa628091b6cf373830f7969e52a9f116 /ftp
parent6b24e477ae8af0ea83e02576f038e47b4d652a91 (diff)
downloadports-51fb72abd81c6f0e55cf42b4f8859d0d50355923.tar.gz
ports-51fb72abd81c6f0e55cf42b4f8859d0d50355923.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/frox/Makefile67
1 files changed, 18 insertions, 49 deletions
diff --git a/ftp/frox/Makefile b/ftp/frox/Makefile
index 844cddee9f8e..9071a9410f6d 100644
--- a/ftp/frox/Makefile
+++ b/ftp/frox/Makefile
@@ -14,27 +14,25 @@ COMMENT= Transparent FTP proxy with caching support
LICENSE= GPLv2
+USES= gmake
USE_BZIP2= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_RC_SUBR= frox
SUB_FILES= pkg-message
-MAN1= frox.1
-MAN5= frox.conf.5
-
PORTDOCS= SECURITY CREDITS ChangeLog FAQ.html FAQ-1.html FAQ-2.html \
FAQ-3.html FAQ-4.html FAQ-5.html FAQ-6.html FAQ-7.html \
FAQ-8.html
-PLIST_FILES= sbin/frox ${EXAMPLESDIR:S,${PREFIX}/,,}/frox.conf
+PLIST_FILES= sbin/frox ${EXAMPLESDIR:S,${PREFIX}/,,}/frox.conf \
+ man/man1/frox.1.gz man/man5/frox.conf.5.gz
PLIST_DIRS= ${EXAMPLESDIR:S,${PREFIX}/,,}
PKGMESSAGE= ${WRKDIR}/pkg-message
CONFIGURE_ARGS= --enable-configfile=${PREFIX}/etc/frox.conf
-OPTIONS_DEFINE= IPFILTER PF VIRUS_SCAN HTTP_CACHE LOCAL_CACHE CCP ROOT_RUN
+OPTIONS_DEFINE= IPFILTER PF VIRUS_SCAN HTTP_CACHE LOCAL_CACHE CCP ROOT_RUN DOCS
OPTIONS_DEFAULT= HTTP_CACHE CCP
IPFILTER_DESC= Use ipfilter instead of ipfw
@@ -45,52 +43,23 @@ LOCAL_CACHE_DESC= Enable use of local cache
CCP_DESC= Ftp-proxy style command control programs
ROOT_RUN_DESC= Allow frox running as root (not recomended)
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MIPFILTER}
-CONFIGURE_ARGS+= --enable-ipfilter
-.endif
-
-.if ${PORT_OPTIONS:MPF}
-CPPFLAGS+= -DPF
-.endif
-
-.if ${PORT_OPTIONS:MVIRUS_SCAN}
-CONFIGURE_ARGS+= --enable-virus-scan
-.endif
-
-.if ${PORT_OPTIONS:MHTTP_CACHE}
-CONFIGURE_ARGS+= --enable-http-cache
-.endif
-
-.if ${PORT_OPTIONS:MLOCAL_CACHE}
-CONFIGURE_ARGS+= --enable-local-cache
-.endif
-
-.if ${PORT_OPTIONS:MCCP}
-CONFIGURE_ARGS+= --enable-ccp
-.endif
-
-.if ${PORT_OPTIONS:MROOT_RUN}
-CONFIGURE_ARGS+= --enable-run-as-root
-.endif
+IPFILTER_CONFIGURE_ENABLE= ipfilter
+PF_CPPFLAGS= DPF
+VIRUS_SCAN_CONFIGURE_ENABLE= virus-scan
+HTTP_CACHE_CONFIGURE_ENABLE= http-cache
+LOCAL_CACHE_CONFIGURE_ENABLE= local-cache
+CCP_CONFIGURE_ENABLE= ccp
+ROOT_RUN_CONFIGURE_ARGS= run-as-root
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/frox ${PREFIX}/sbin
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/src/frox.conf ${EXAMPLESDIR}/frox.conf
- ${INSTALL_MAN} ${WRKSRC}/doc/frox.man ${MANPREFIX}/man/man1/frox.1
- ${INSTALL_MAN} ${WRKSRC}/doc/frox.conf.man ${MANPREFIX}/man/man5/frox.conf.5
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/frox ${STAGEDIR}${PREFIX}/sbin
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/src/frox.conf ${STAGEDIR}${EXAMPLESDIR}/frox.conf
+ ${INSTALL_MAN} ${WRKSRC}/doc/frox.man ${STAGEDIR}${MANPREFIX}/man/man1/frox.1
+ ${INSTALL_MAN} ${WRKSRC}/doc/frox.conf.man ${STAGEDIR}${MANPREFIX}/man/man5/frox.conf.5
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
- @${STRIP_CMD} ${PREFIX}/sbin/frox; \
- ${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>