aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-10-15 20:16:10 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-10-15 20:16:10 +0000
commit5e0de1cddd93ba68508ec7d43e7b452ebd350370 (patch)
tree4c2cf320da1661d00b0bdbdab7c4ea47c5bd0cb0 /ftp
parentd8f2449fd6cbe34d9df0ba12d438ead501cab352 (diff)
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curlpp/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/ftp/curlpp/Makefile b/ftp/curlpp/Makefile
index f305887d2270..c623a3ae88fa 100644
--- a/ftp/curlpp/Makefile
+++ b/ftp/curlpp/Makefile
@@ -11,18 +11,18 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= C++ wrapper for libcurl
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
OPTIONS_DEFINE= BOOST DOCS EXAMPLES
CONFIGURE_ARGS= --disable-ewarning
-CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-LDFLAGS+= -L${LOCALBASE}/lib
+PATHFIX_MAKEFILEIN= Makefile.am
USE_LDCONFIG= yes
-USES= autoreconf libtool pathfix
+USES= autoreconf libtool localbase pathfix
PORTDOCS= *
PORTEXAMPLES= *
@@ -30,8 +30,6 @@ PORTEXAMPLES= *
GH_ACCOUNT= jpbarrette
USE_GITHUB= yes
-PATHFIX_MAKEFILEIN= Makefile.am
-
BOOST_BUILD_DEPENDS= boost-libs>=1.20.0:${PORTSDIR}/devel/boost-libs
BOOST_RUN_DEPENDS= ${BOOST_BUILD_DEPENDS}
BOOST_CONFIGURE_ON= --with-boost=${LOCALBASE}
@@ -40,9 +38,11 @@ BOOST_CONFIGURE_OFF= --without-boost
post-patch:
@${REINPLACE_CMD} -e 's| -lstdc++||' ${WRKSRC}/configure.ac
-post-install:
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/doc/guide.pdf ${STAGEDIR}${DOCSDIR}/
+
+post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
${INSTALL_DATA} ${WRKSRC}/examples/README ${WRKSRC}/examples/example*.cpp ${STAGEDIR}${EXAMPLESDIR}/