aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-11-08 14:47:00 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-11-08 14:47:00 +0000
commitc4927e043cf01f73da57920698b695c0c6cf3e64 (patch)
tree448a74c1d2fa9218ed879cc777821d13e1e1a9e8 /ftp
parent3cf0c52fa6016687078f1be15489ab2af19dc330 (diff)
downloadports-c4927e043cf01f73da57920698b695c0c6cf3e64.tar.gz
ports-c4927e043cf01f73da57920698b695c0c6cf3e64.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/filezilla/Makefile3
-rw-r--r--ftp/gftp/Makefile2
-rw-r--r--ftp/horde-gollem/Makefile2
-rw-r--r--ftp/pavuk/Makefile3
-rw-r--r--ftp/phpwebftp/Makefile2
-rw-r--r--ftp/pureadmin/Makefile2
-rw-r--r--ftp/urlgfe/Makefile2
-rw-r--r--ftp/yafc/Makefile4
8 files changed, 11 insertions, 9 deletions
diff --git a/ftp/filezilla/Makefile b/ftp/filezilla/Makefile
index ab517c6ece5b..cdb68b922688 100644
--- a/ftp/filezilla/Makefile
+++ b/ftp/filezilla/Makefile
@@ -25,7 +25,8 @@ LIB_DEPENDS= libfilezilla.so:ftp/libfilezilla \
RUN_DEPENDS= xdg-open:devel/xdg-utils
INSTALLS_ICONS= yes
-USES= compiler:c++14-lang gmake iconv:wchar_t localbase pkgconfig sqlite tar:bzip2
+USES= compiler:c++14-lang gmake gnome iconv:wchar_t localbase \
+ pkgconfig sqlite tar:bzip2
USE_GNOME= cairo gtk20
USE_WX= 3.0
WX_CONF_ARGS= relative
diff --git a/ftp/gftp/Makefile b/ftp/gftp/Makefile
index c1d7ab95e8c7..473ef3499882 100644
--- a/ftp/gftp/Makefile
+++ b/ftp/gftp/Makefile
@@ -12,7 +12,7 @@ COMMENT= Free multithreaded GTK-based FTP and SFTP client
LICENSE= GPLv2
-USES= pathfix pkgconfig tar:bzip2 ssl
+USES= gnome pathfix pkgconfig ssl tar:bzip2
GNU_CONFIGURE= yes
USE_GNOME= glib20 gtk20
CFLAGS+= -D_WANT_SEMUN
diff --git a/ftp/horde-gollem/Makefile b/ftp/horde-gollem/Makefile
index 577b67fe2dbc..680f7593237b 100644
--- a/ftp/horde-gollem/Makefile
+++ b/ftp/horde-gollem/Makefile
@@ -12,7 +12,7 @@ COMMENT= Horde Web-based File Manager
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= horde cpe
+USES= cpe horde php
USE_PHP= gettext json
USE_HORDE_BUILD= Horde_Role
USE_HORDE_RUN= Horde_Role \
diff --git a/ftp/pavuk/Makefile b/ftp/pavuk/Makefile
index bdb4ebd7d42a..becc46b61ef1 100644
--- a/ftp/pavuk/Makefile
+++ b/ftp/pavuk/Makefile
@@ -13,7 +13,7 @@ COMMENT= HTTP, FTP, and Gopher mirroring tool
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= localbase tar:bzip2 ssl
+USES= localbase ssl tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-locale-dir=${PREFIX}/share/locale \
--disable-debug --disable-gnome --disable-js \
@@ -28,6 +28,7 @@ NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
GTK2_CONFIGURE_ENABLE= gtk
+GTK2_USES= gnome
GTK2_USE= GNOME=gtk20
DANTE_CONFIGURE_ENABLE= socks
diff --git a/ftp/phpwebftp/Makefile b/ftp/phpwebftp/Makefile
index e9b4ead1bc05..7f6d872595da 100644
--- a/ftp/phpwebftp/Makefile
+++ b/ftp/phpwebftp/Makefile
@@ -12,7 +12,7 @@ COMMENT= Set of PHP-scripts to manage FTP over the web
LICENSE= GPLv2
-USES= zip
+USES= php zip
NO_BUILD= yes
NO_ARCH= yes
USE_PHP= ftp
diff --git a/ftp/pureadmin/Makefile b/ftp/pureadmin/Makefile
index d54e30a54c75..1d5c23fefe40 100644
--- a/ftp/pureadmin/Makefile
+++ b/ftp/pureadmin/Makefile
@@ -13,7 +13,7 @@ COMMENT= Management utility for the PureFTPd
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= fam gettext gmake localbase pathfix pkgconfig
+USES= fam gettext gmake gnome localbase pathfix pkgconfig
USE_GNOME= intltool libglade2
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/ftp/urlgfe/Makefile b/ftp/urlgfe/Makefile
index 4b43a535a3cc..cb0bd0339dcc 100644
--- a/ftp/urlgfe/Makefile
+++ b/ftp/urlgfe/Makefile
@@ -13,7 +13,7 @@ COMMENT= Download manager
LIB_DEPENDS= libcurl.so:ftp/curl
GNU_CONFIGURE= yes
-USES= dos2unix libtool pkgconfig ssl
+USES= dos2unix gnome libtool pkgconfig ssl
USE_GNOME= gtk20
OPTIONS_DEFINE= DOCS NLS
diff --git a/ftp/yafc/Makefile b/ftp/yafc/Makefile
index d7d8ed694241..85f88f181168 100644
--- a/ftp/yafc/Makefile
+++ b/ftp/yafc/Makefile
@@ -17,7 +17,7 @@ LICENSE= GPLv2+
OPTIONS_DEFINE= BASH EXAMPLES NLS SSH READLINE
OPTIONS_DEFAULT=BASH SSH
-USES= gmake tar:xz ssl
+USES= gmake ssl tar:xz
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_ipv6=yes
CONFIGURE_ARGS= --with-socks=no --with-socks5=no --with-krb4=no \
@@ -31,7 +31,7 @@ PLIST_FILES= bin/yafc \
man/man1/yafc.1.gz
INFO= yafc
-NLS_USES= gettext
+NLS_USES= gettext gnome
NLS_USE= GNOME=intltool
NLS_CONFIGURE_WITH= gettext=${LOCALBASE}
NLS_PLIST_FILES= share/locale/de/LC_MESSAGES/yafc.mo \