aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2009-01-26 02:11:01 +0000
committerPeter Pentchev <roam@FreeBSD.org>2009-01-26 02:11:01 +0000
commitbd3c754a8f797953190cee6b158b7161b1748bde (patch)
tree5a2b9272eb2761902bf188e1453c83709c6fb438 /ftp
parent731195e5196ba274b957a08babe0c77374bf7f39 (diff)
downloadports-bd3c754a8f797953190cee6b158b7161b1748bde.tar.gz
ports-bd3c754a8f797953190cee6b158b7161b1748bde.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile7
-rw-r--r--ftp/curl/files/patch-lib::ftp.c47
2 files changed, 54 insertions, 0 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 46ef4acdf402..2ca954c957be 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -202,6 +202,13 @@ post-install:
# Setting LC_ALL=C is a kludge; maybe curl/libcurl shouldn't actually use
# the user's locale when dates are sent to the server.
test: build
+.if defined(WITHOUT_PROXY)
+ @${ECHO_MSG} "******************************************"
+ @${ECHO_MSG} "* You have disabled curl proxy support. *"
+ @${ECHO_MSG} "* Some tests SHALL FAIL! *"
+ @${ECHO_MSG} "* This is being addressed. *"
+ @${ECHO_MSG} "******************************************"
+.endif
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} LC_ALL=C ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
.include <bsd.port.post.mk>
diff --git a/ftp/curl/files/patch-lib::ftp.c b/ftp/curl/files/patch-lib::ftp.c
new file mode 100644
index 000000000000..d2a0b8e3f965
--- /dev/null
+++ b/ftp/curl/files/patch-lib::ftp.c
@@ -0,0 +1,47 @@
+--- ../../../tags/curl-7.19.2-stock/lib/ftp.c 2009-01-23 18:11:47.000000000 +0200
++++ lib/ftp.c 2009-01-26 03:31:07.000000000 +0200
+@@ -1901,7 +1901,7 @@
+ result = CURLE_COULDNT_CONNECT;
+ break;
+ }
+-#ifndef CURL_DISABLE_HTTP
++#if !defined(CURL_DISABLE_HTTP) && !defined(CURL_DISABLE_PROXY)
+ if(conn->bits.tunnel_proxy && conn->bits.httpproxy) {
+ /* FIX: this MUST wait for a proper connect first if 'connected' is
+ * FALSE */
+@@ -1927,7 +1927,7 @@
+ if(CURLE_OK != result)
+ return result;
+ }
+-#endif /* CURL_DISABLE_HTTP */
++#endif /* CURL_DISABLE_HTTP || CURL_DISABLE_PROXY */
+
+ state(conn, FTP_STOP); /* this phase is completed */
+
+@@ -3056,7 +3056,7 @@
+ bool *done) /* see description above */
+ {
+ CURLcode result;
+-#ifndef CURL_DISABLE_HTTP
++#if !defined(CURL_DISABLE_HTTP) && !defined(CURL_DISABLE_PROXY)
+ /* for FTP over HTTP proxy */
+ struct HTTP http_proxy;
+ struct FTP *ftp_save;
+@@ -3079,7 +3079,7 @@
+
+ ftpc->response_time = RESP_TIMEOUT; /* set default response time-out */
+
+-#ifndef CURL_DISABLE_HTTP
++#if !defined(CURL_DISABLE_HTTP) && !defined(CURL_DISABLE_PROXY)
+ if(conn->bits.tunnel_proxy && conn->bits.httpproxy) {
+ /* BLOCKING */
+ /* We want "seamless" FTP operations through HTTP proxy tunnel */
+@@ -3102,7 +3102,7 @@
+ if(CURLE_OK != result)
+ return result;
+ }
+-#endif /* CURL_DISABLE_HTTP */
++#endif /* CURL_DISABLE_HTTP || CURL_DISABLE_PROXY */
+
+ if(conn->protocol & PROT_FTPS) {
+ /* BLOCKING */